[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: updateing ARGHH.



On Mon, 19 Jan 2009 14:39:59 -0500, Michael wrote:

> [root merlin Michael]# yum update

> ---> Package ffmpeg.i386 0:0.4.9-28_r15845.fc10 set to be updated

This is a package from atrpms, which contains newer library versions.
It looks like you lose the rpmfusion.org ffmpeg-libs package during
this update attempt.

> But you don't understand silly computer.... I have that file...

Only _before_ pulling in updates. All the packages which are offered
as update can also remove existing files and replace them with other
files. Something is taking away the needed libavcodec.so.51
Don't forget that.
 
> [root merlin lib]# ls -l libavcode*
> lrwxrwxrwx 1 root root      21 2009-01-15 12:05 libavcodec.so.51 -> 
> libavcodec.so.51.71.0
> -rwxr-xr-x 1 root root 3517336 2008-11-20 14:44 libavcodec.so.51.71.0
> lrwxrwxrwx 1 root root      20 2009-01-15 22:05 libavcodec.so.52 -> 
> libavcodec.so.52.3.0
> -rwxr-xr-x 1 root root 5104808 2008-11-23 11:37 libavcodec.so.52.3.0

Query the RPM database, NOT the local filesystem:

  rpm -qf /usr/lib/libavcodec*

Then see whether the package that contains these files will survive your
update.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]