[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Hosed fstab, won't boot how to edit?



Robert Moskowitz wrote:
Roger Heflin wrote:
On Tue, Jan 20, 2009 at 1:45 PM, Robert Moskowitz



mount -o rw,remount /

So I tried this (had a DAH moment after you posted this), but got an error:

mount: / not mounted already, or bad option

So I tried just 'mount' to see what the status of / is and got (amongst other pieces of info):

/dev/sda1 on / type ext3 (rw)
then edit it.


mount is not reliable to show what is mounted in some cases.

It reads /etc/mtab a file that happens to be located on a ro filesystem that won't have been updated so it won't be right when a machine is in single user mode.

do a "cat /proc/mounts" to figure out what the actual state is, I never use the mount command to see what is mounted there are just too many failures of it (it only shows the options that you used, not (in the case of nfs) the actual parameters being used).

try doing a "mount -o remount,rw /" I know I have done this several times.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]