[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: database mess up



On Fri, 2009-01-23 at 19:49 +0200, Panu Matilainen wrote:
> >>> http://www.rpm.org/wiki/Docs/RpmRecovery
> >> OK, but /usr/lib/rpm/rpmdb_sta is not part of rpm for fedora !
> >> Regards
> > ----
> > indeed - they seem to have removed the db4 utilities from rpmdb
> 
> Rpm in F10 no longer uses an internal copy of db4 so this isn't 
> practical to do anymore.
> 
> > even worse, I installed db4-utils package and ran...
> >
> > # cd /var/lib/rpm
> > # db_dump Packages
> > db_dump: Program version 4.7 doesn't match environment version 4.5
> > db_dump: DB_ENV->open: DB_VERSION_MISMATCH: Database environment version
> > mismatch
> >
> > which means that I can't use db4-utils to do anything with rpmdb on
> > Fedora 10
> 
> Use the db45_foo variants instead, eg db45_dump
----
good to know...do I gather that you have little faith for the...

db45_dump /var/lib/rpm/Packages.old \
| db45_load /var/lib/rpm/Packages 

mechanics to suggest that he essentially download every package and
re-add them to --justdb which seems like a rather Herculean task?

Craig


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]