[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: "Static" wireless interface and runlevel 3



On 01/26/2009 11:24:05 AM, Todd Zullinger wrote:
> Mike Cloaked wrote:
> >> I do have NetworkManager starting my WPA wireless connection prior
> >> to login on my laptop.
> >
> > I have been wanting to do that for ages - I still could not do it 
> in
> > F10 - please tell us the magic recipe?
> 
> I edited /etc/NetworkManager/nm-system-settings.conf and added 
> keyfile
> to the plugins setting:
> 
> $ cat /etc/NetworkManager/nm-system-settings.conf
> [main]
> plugins=ifcfg-fedora,keyfile
> 
> Then I opened the NM connection editor (from my user account,
> available by right-clicking on the NM applet and selecting "Edit
> Connections" or by calling nm-connection from a terminal).  In the
> connection editor, I selected the connection I wanted, clicked Edit,
> and checked the "Available to all users" box at the bottom, and
> clicked Apply.
> 
> This should prompt you to allow the action and then create a file in
> /etc/NetworkManager/system-connections/.  I do recall having to futz
> with this a little, perhaps creating that directory and looking in 
> the
> PolicyKit authorizations (System->Preferences->System->Authorizations
> or polkit-gnome-authorization).
> 
> Of course, this was right after F10 was released and NM updates since
> then may have obviated the need for any of that.  I mention it as
> possible things to look at if you have problems.  Another option 
> might
> be to run nm-connection as root and adding your connections directly,
> but I have not tried that.
> 
> Hopefully that helps.  I'm certainly not an expert on the NM stuff, 
> so
> if it doesn't, I may not be of much more use. :)

OK, here's what I tried.

Added ",keyfile" to the .conf. Rebooted. Accessed the connection editor 
and checked the box as indicated.  On apply, was prompted for a 
password. Without too much thought, gave it the root pw. That failed,
and now the daemon password checker has me on its list and won't give 
me a second chance. Drat!

Might have to do with policykit authorizations, but not obvious which!




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]