[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: F10 Cups / Samba / Vista



On Wed, 2009-01-28 at 10:56 -0500, Brian C. Huffman wrote:
> Craig White wrote:
> > 
> > The point was of course to help the OP figure out why he couldn't 
> print
> > and it seemed likely that I had long ago 'uncommented' the raw 
> printing
> > protection in my mime.convs and mime.types and some update at some 
> point
> > simply over wrote the mime.convs file and never bothered leaving a
> > mime.convs.rpmnew file and I suspect that is what happened to the OP 
> and
> > why it worked previously in Fedora-9 but not now in Fedora-10.
> >
> > The samba link I provided gives a complete explanation including the
> > alterations necessary to enable raw printing.
> >
> > Craig
> 
> As I said I had this working in F9 and I backed up the entire cups 
> directory as well as /etc/samba before the upgrade.  Indeed both my 
> mime.types and mime.convs files still have the appropriate lines 
> uncommented and I've tried the same magic (as F9) for the smb.conf file 
> with no luck.
> 
> It appears to me that this is some sort of problem between samba and 
> cups on the server since I can connect to samba shares fine and I can 
> *see* the printer when browsing from the vista box.
> 
> I personally would like to get this working, but the alternative that 
> someone suggested about just making it a network printer and pointing to 
> the http address for cups (bypassing samba) does work.  I'm just 
> thinking that I might want to use this machine as a fileserver at some 
> point and there's no need to use two points of entry if one works.
> 
> So....if anyone else has any ideas as to why this doesn't work, I'd 
> still appreciate it, but if not, the "direct to cups" will do for now.
----
When you stated 'I backed up the entire cups directory' that sort of
suggests that you also restored it after the upgrade which may have been
the cause of this problem.

Did you 'replace' any of the files in /etc/cups with those you 'backed'
up?

Can you confirm that you can print a test page directly on the F10
system that's running cups?

You also might want to look for clues in /var/log/cups/error_log - this
might not actually be a samba issue.

Craig


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]