[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

grub install failed with latest F10 update



I have Googled this problem and tried everything I can think of to fix it, 
but no luck.  I hope someone can help.

I have a Nvidia based motherboard, two SATA drives running with NVRaid 1.  
I upgraded to F10 from F8 and used the scsi_mod.scan=sync kernel option to 
get around the RAID problem, then did the mkinitrd update, then updates 
including kernel 2.6.27.9-159.  All was well, and I have been using and 
updating since Jan 12 until today.

With today's update, I finished the updates and rebooted and got the GRUB 
prompt.  OK, no problem, I booted from the F10 DVD, entered rescue mode, 
and ran:

chroot /mnt/sysimage

grub
grub> find /grub/grub.conf
 (hd0,2)
 (hd1,2)   [note that it is NVRaid1, so found both drives]
grub> root (hd0,2)
 Filesystem type is ext2fs, partition type 0x83
grub> setup (hd0)
 checking if "/boot/grub/stage1" exists... no
 checking if "/grub/stage1" exists... yes
 checking if "/grub/stage2" exists... yes
 checking if "/grub/e2fs_stage1_5"exists... yes
 running "embed /grub/e2fs_stage1_5 (hd0)... 23 sectors are embedded
succeeded
 running "install /grub/stage1 (hd0) (hd0)1+23 p (hd0,2)/grub/stage2 /grub/grub.conf"... failed

error 22t: no such partition


OK, I also tried (hd1,2), and got the same exact messages except for the substitution of (hd1)

I exited grub shell and tried grub-install /dev/sda
got: /dev/sda does not have any corresponding BIOS drive

my device.map file is:
(hd0)  /dev/mapper/nvidia_adgbjghc

The device.map file is the same as it has always been, no change.

This is a Linux only machine, no dual boot.  Partitions are:
/dev/mapper/nvidia_adgbjghcp1 vfat
/dev/mapper/nvidia_adgbjghcp2 ext3
/dev/mapper/nvidia_adgbjghcp3 ext3 /boot
/dev/mapper/nvidia_adgbjghcp4 extended
/dev/mapper/nvidia_adgbjghcp5 ext3 /
/dev/mapper/nvidia_adgbjghcp6 swap

I also tried booting the rescue with and without the scsi_mod.scan=sync
with no difference in the outcome.  I have done this grub reinsall on
many different systems and never had this problem.  Although they were not
RAID systems of any kind.  I have never had to do a grub install on this
system until today.  I don't know if it is related to NVRaid, RAID in
general, or something else.

Any suggestions would be appreciated, other than telling me to use Linux
software RAID.  I want to get this configuration running.

Thank you in advance,
Lloyd



      


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]