[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: grub hangs after update

On 2009-01-28 14:04, Mark C. Allman wrote:
I saw the same thing about a week ago.  The problem was the master boot
record (MBR).  This is how I fixed it (note that I backed everything up
one more time before doing this).
<disclaimer>Please note that this rebuilds the MBR so it's not to be
tried without understanding what you're doing</disclaimer>

1.  Boot from a rescue disk to "repair" the system.
2.  Let the start-up process find and mount your filesystem.
3.  Chroot to /mnt/sysimage
4.  Look at /etc/grub.conf to both be sure it looked OK and to
    look for the "root (hd0,0)" or "root (hd0,1)" or whatever line.
5.  Run "grub"
    5a.  type in "root (hd0,0)", which is what I found in grub.conf
    5b.  type "setup (hd0)"
6.  Rebooted the system and it all started up.

Take a look at the page:

Thanks.  This did the trick.

-- Mark C. Allman, PMP
-- Allman Professional Consulting, Inc.
-- www.allmanpc.com, 617-947-4263

Consulting IT Project/Program Management: on-time, on-budget

On Wed, 2009-01-28 at 09:23 +0100, Sjoerd Mullender wrote:
Yesterday I updated several F10 systems and got, among other things, a
new kernel.  All systems were reasonably up-to-date (less than a week).
On two systems, when I boot, grub hangs after just displaying GRUB.  The
other updated systems booted without problems.

The two affected systems are a Dell Inspiron 1720 (64 bit OS) and a Dell
Inspiron 8200 (32 bit).

Has anybody else seen this?  Does anybody have a suggestion on how to
fix this?

Sjoerd Mullender

Sjoerd Mullender

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]