[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Slooooow USB key speeds



Hi All,

I have a Kingston 8G DataTraveler USB stick.  When I plug it into one of
the USB 2.0 ports on my Fedora 10 PC (x86_64), the kernel detects it,
and after some magic, Gnome mounts it on my desktop - everything is
honkey dorey.

When I use Nautilus to copy files to it (say a 1 GB movie file), the
transfer speed begins in the 20 MBps range, but quickly drops to 1.5
MBps or less.  Obviously, this increases transfer time exceptionally,
essentially rendering the USB stick useless.

I've tried reformatting (as vfat) the stick, deleting and recreating the
partition on it, all several times and to no avail.

The same stick works just fine on my HP Compaq nx7400 Fedora 10 laptop.
I now assume something is either amiss with my PC, or there's a bug
somewhere in Fedora 10 killing USB performance.  I've tried searching
for both, but I've come up up with nada.

My PC has an Asus P5Q-E motherboard, an Intel E8400, and 4 GB of RAM. Is
there something about this combination of hardware (don't forget the USB
stick) when used in conjunction with the x86_64 version of Fedora 10,
leads to shitty USB performance?

Regards,

Ranbir
-- 
Kanwar Ranbir Sandhu
Linux 2.6.27.9-159.fc10.x86_64 x86_64 GNU/Linux 
16:15:12 up 11 days, 20:31, 4 users, load average: 1.25, 0.83, 0.40 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]