[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Slooooow USB key speeds



Kanwar Ranbir Sandhu wrote:
Hi All,

I have a Kingston 8G DataTraveler USB stick.  When I plug it into one of
the USB 2.0 ports on my Fedora 10 PC (x86_64), the kernel detects it,
and after some magic, Gnome mounts it on my desktop - everything is
honkey dorey.

When I use Nautilus to copy files to it (say a 1 GB movie file), the
transfer speed begins in the 20 MBps range, but quickly drops to 1.5
MBps or less.  Obviously, this increases transfer time exceptionally,
essentially rendering the USB stick useless.

I've tried reformatting (as vfat) the stick, deleting and recreating the
partition on it, all several times and to no avail.

The same stick works just fine on my HP Compaq nx7400 Fedora 10 laptop.
I now assume something is either amiss with my PC, or there's a bug
somewhere in Fedora 10 killing USB performance.  I've tried searching
for both, but I've come up up with nada.

My PC has an Asus P5Q-E motherboard, an Intel E8400, and 4 GB of RAM. Is
there something about this combination of hardware (don't forget the USB
stick) when used in conjunction with the x86_64 version of Fedora 10,
leads to shitty USB performance?

A lot of machines have several USB controllers--some USB 1.1 and some
USB 2.0.  If you happen to plug the key into one of the 1.1 ports, it'll
be quite a bit slower than the 2.0 ports.

Plug the key into one of your ports, then do "lsusb".  In that listing,
you'll see lines with "Device: 001".  Those are the "hubs" and they'll
tell you if it's a V1.1 or V2.0 bus.

You should also see your key.  If it's on a V1.1 bus, try moving it to
another port to get it on a V2.0 bus.  For example, here's one of mine:

[root bigdog ~]# lsusb
Bus 001 Device 002: ID 2040:6513 Hauppauge WinTV HVR-980
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 002: ID 413c:3200 Dell Computer Corp. MouseBus 001 Device 001:
Bus 002 Device 003: ID 413c:2105 Dell Computer Corp.
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

Note that that device "Bus 001 Device 001" is a 2.0 hub, "Bus 002 Device 001" is a 1.1 hub. You'll also notice that my USB TV tuner card is on
bus 001 (the 2.0 bus), and my keyboard and mouse are on bus 002 (the 1.1
bus).

Also note that all three devices are plugged into the back of my
machine.  The two USB ports next to the PCI bus slots are the 1.1 ports,
while the ports next to my sound card jacks are the 2.0 ports.  The two
ports on the front panel (connected to the mobo by a cable) also seem
to be 2.0 ports (bus 001).

I just LOVE consistency!
----------------------------------------------------------------------
- Rick Stevens, Systems Engineer                      ricks nerd com -
- AIM/Skype: therps2        ICQ: 22643734            Yahoo: origrps2 -
-                                                                    -
- If at first you don't succeed, quit. No sense being a damned fool! -
----------------------------------------------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]