[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Yum error when attempting an update





2009/1/29 Thorsten Leemhuis <fedora leemhuis info>
On 29.01.2009 02:55, David Burns wrote:
On Wed, Jan 28, 2009 at 12:39 PM, John Lagrue <jlagrue gmail com> wrote:
2009/1/27 Phil Meyer <pmeyer themeyerfarm com>
John Lagrue wrote:
Attempting an update this evening I get the following error.

--------------------------------------------------------------
Downloading Packages:
============================== Entering rpm code
===============================
Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve:
kernel-uname-r is needed by (installed)
kmod-nvidia-2.6.27.5-37.fc9.i686-173.14.15-1.fc9.5.i686
My guess is that kmod-nvidia (or something related) has not been
updated to match the new kernel yet.

Wrong guess. The modules were in the repo on the same day as the new kernel (within hours after that one got out; wasn't quicker as I was asleep when the new kernel got pushed).


kernel-uname-r is needed by (installed)
kmod-nvidia-2.6.27.5-41.fc9.i686-173.14.15-1.fc9.6.i686
kernel-uname-r is needed by (installed)
kmod-nvidia-2.6.27.7-53.fc9.i686-173.14.15-1.fc9.7.i686
Complete!
(1, [u'Please report this error in http://yum.baseurl.org/report'
<http://yum.baseurl.org/report%27>])

These are all kernels and those are reports for the kmod that are on the system. John, did you maybe remove the kernels 2.6.27.5-37.fc9.i686 2.6.27.5-41.fc9.i686 and 2.6.27.7-53.fc9.i686 with "--nodeps"?

But whatever, this command should solve the problem:

rpm -e kmod-nvidia-2.6.27.5-37.fc9.i686-173.14.15-1.fc9.5.i686 kmod-nvidia-2.6.27.5-41.fc9.i686-173.14.15-1.fc9.6.i686 kmod-nvidia-2.6.27.7-53.fc9.i686-173.14.15-1.fc9.7.i686

Then run yum-update

CU
knurd

--

Thank you - that fixed it :)

JDL


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]