[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Package Installer



On Sun, May 31, 2009 at 10:54 PM, C Li <vishwin80 gmail com> wrote:
>> How can I get package installer to run in a GUI (gnome) as root.  I keep
>> getting a message that says "You do not have sufficient privileges to
>> run this operation".
>>
> Use su -c 'gpk-install-local-file x.rpm' or sudo gpk-install-local-file
> x.rpm, where x.rpm is the rpm you are trying to install.
>
> Or, you could try adding your user into the root group.

Wrong, sorry. The reason that it's not going to run as root is because
unless you've setup PolicyKit to do otherwise, it's not going to work
correctly, so gnome-packagekit detects uid 0 and warns you.

Running a PackageKit GUI as root is not a good plan at all. With
GTK_MODULES a malicious user could silently install software. It's
totally insecure.

Richard.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]