[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: WUSB54G firmware

On 06/01/2009 12:51 PM, suvayu ali wrote:
2009/6/1 Jim<mickeyboa sbcglobal net>:
On 05/31/2009 01:36 PM, Suvayu Ali wrote:
Jim wrote:
On 05/31/2009 02:21 AM, Paulo Cavalcanti wrote:

On Sat, May 30, 2009 at 10:47 PM, Jim<mickeyboa sbcglobal net
<mailto:mickeyboa sbcglobal net>>  wrote:


    I'm trying to setup a Linksys WUSB54G and I get this error message
    from DMESG.

    usb 2-2: firmware: requesting l3886usb

    usb 2-2: (p54usb) cannot find firmware (isl3886usb)

    usb 2-2: firmware: requesting isl3890usb

    p54usb: probe of 2-2:1.0 failed with error -2
    usbcore: registered new interface driver p54usb

    I have googled isl3886USB and can't find the firmware, does anyone
    know where this firmware

I am pretty sure I used one of those on F8, and it worked out of the

Anyway, take a look at


which will take you to:


Paulo Roma Cavalcanti
I should have told you that I'm trying install on a X86_64 box.

I did install the and it is in /lib/firmware, it
would not install in

I think I need to install the ndiswrapper for i386, I have
ndiswrapper.X86_64 installed.

The ndiswrapper.i386 doesn't show up in FC10 X86_64 fedora repo how do I
change the repo's to read the i386 files ?

I think you missed a crucial step. Although right now I am using a D-Link
USB wifi receiver, I did try a Linksys for a few days after I had set it up
for the D-Link, and it worked right out of the box. So the procedure should
be the same. Here is how I did it for the D-Link.

1. I put the firmware in /lib/firmware/
2. Renamed it to 'isl3890usb'
2. in /lib/modules/`uname -r`/build/ ran "make menuconfig" as root,
enabled the relevant kernel module. then did a "modprobe<driver>". Here
<driver>  is p54.

I believe you missed the renaming the firmware part.


PS: I am on x86_64 too
$uname -r

I did as you suggested, but I'm still having problems.
Do you know what this means?

p54usb: probe of 2-2:1.0 failed with error -110

Here is my dmesg and lsmod


usb 2-2: (p54usb) cannot find firmware (isl3886usb)
usb 2-2: firmware: requesting isl3890usb
phy0: p54 detected a LM86 firmware
p54: rx_mtu reduced from 3240 to 2392
phy0: FW rev - Softmac protocol 5.9
phy0: cryptographic accelerator WEP:YES, TKIP:YES, CCMP:YES

p54usb: probe of 2-2:1.0 failed with error -110
usbcore: registered new interface driver p54usb

# dmesg|grep firmware
firmware: requesting isl3890usb
p54: LM86 firmware

# dmesg|grep prism
usbcore: registered new interface driver prism54usb
Loaded prism54 driver, version 1.2

This is my output from dmesg. Its rather odd that in your case the
kernel is looking for two different firmwares for the same device.

Modules that are loading

p54usb                 14208  0
p54common              20452  1 p54usb
mac80211              194224  2 p54usb,p54common

As you can see from this device list, your adapter is not there.

However filtering the complete device list for Linksys gives me a list
where it is included.

Are you sure you have the correct model *name* *and* *revision* for the adapter?

If you have that correct then the next step would be to check the
settings in menuconfig. This is what you should see when you search
for prism after running make menuconfig.

   │ Symbol: PRISM54 [=m]
   │ Prompt: Intersil Prism GT/Duette/Indigo PCI/Cardbus
   │   Defined at drivers/net/wireless/Kconfig:496
   │   Depends on: NETDEVICES&&  !S390&&  PCI&&  EXPERIMENTAL&&  WLAN_80211
   │   Location:
   │     ->  Device Drivers
   │       ->  Network device support (NETDEVICES [=y])
   │         ->  Wireless LAN
   │           ->  Wireless LAN (IEEE 802.11) (WLAN_80211 [=y])
   │   Selects: WIRELESS_EXT&&  FW_LOADER

After that is verified, try 'modprobe prism54'. I was quoting from
memory in my last email and had erroneously said p54. If all of this
doesn't work, I am out of ideas. I am very new to linux myself. :P


What is the difference between p54usb, p54common, prism54 driver.
The p54usb, p54common always loads at bootup,
but the prism54 doesn't.
I have to modprobe prism54 to get it to load.
Which one is the correct driver ??

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]