[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ibssl.so.7 ?!



On Tue, 2009-06-02 at 21:53 -0300, Martín Marqués wrote:
> 2009/6/2 Germán Racca <german racca gmail com>:
> > On Wed, 2009-06-03 at 02:12 +0200, Kevin Kofler wrote:
> >> Germán Racca wrote:
> >> > Once I upgraded to Rawhide, I've disabled Rawhide and had enabled
> >> > only Fedora 11 Updates.
> >>
> >> Have you run a "yum update" after that? (You should.)
> >>
> >> And you'll also need to enable fedora.repo, not just fedora-updates.repo.
> >>
> >>         Kevin Kofler
> >
> > Yes, I have run 'yum update' and I have enabled fedora.repo also.
> 
> Germán, the problem is that preupgrade leaves out a bunch of kde apps:
> 
> Checking for new repos for mirrors
>  * preupgrade: fedora.c3sl.ufpr.br
> 6:kdelibs-4.2.3-2.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libssl.so.7()(64bit) is needed by package
> 6:kdelibs-4.2.3-2.fc10.x86_64 (installed)
> gpac-libs-0.4.5-3.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libssl.so.7()(64bit) is needed by package
> gpac-libs-0.4.5-3.fc10.x86_64 (installed)
> gstreamer-plugins-bad-0.10.9-1.fc10.x86_64 from installed has
> depsolving problems
>   --> Missing Dependency: libssl.so.7()(64bit) is needed by package
> gstreamer-plugins-bad-0.10.9-1.fc10.x86_64 (installed)
> livna-config-display-0.0.22-1.fc10.noarch from installed has depsolving problems
>   --> Missing Dependency: python(abi) = 2.5 is needed by package
> livna-config-display-0.0.22-1.fc10.noarch (installed)
> gstreamer-plugins-bad-extras-0.10.9-1.fc10.x86_64 from installed has
> depsolving problems
>   --> Missing Dependency: libcrypto.so.7()(64bit) is needed by package
> gstreamer-plugins-bad-extras-0.10.9-1.fc10.x86_64 (installed)
> gstreamer-plugins-bad-extras-0.10.9-1.fc10.x86_64 from installed has
> depsolving problems
>   --> Missing Dependency: libssl.so.7()(64bit) is needed by package
> gstreamer-plugins-bad-extras-0.10.9-1.fc10.x86_64 (installed)
> PyQt4-4.4.4-6.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: python(abi) = 2.5 is needed by package
> PyQt4-4.4.4-6.fc10.x86_64 (installed)
> gstreamer-plugins-bad-extras-0.10.9-1.fc10.x86_64 from installed has
> depsolving problems
>   --> Missing Dependency: libmysqlclient.so.15()(64bit) is needed by
> package gstreamer-plugins-bad-extras-0.10.9-1.fc10.x86_64 (installed)
> 7:kdegraphics-libs-4.2.3-1.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libexiv2.so.4()(64bit) is needed by package
> 7:kdegraphics-libs-4.2.3-1.fc10.x86_64 (installed)
> gstreamer-plugins-ugly-0.10.10-2.fc10.x86_64 from installed has
> depsolving problems
>   --> Missing Dependency: libcdio.so.7()(64bit) is needed by package
> gstreamer-plugins-ugly-0.10.10-2.fc10.x86_64 (installed)
> gpac-libs-0.4.5-3.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libcrypto.so.7()(64bit) is needed by package
> gpac-libs-0.4.5-3.fc10.x86_64 (installed)
> kdeedu-math-4.2.3-1.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libpython2.5.so.1.0()(64bit) is needed by
> package kdeedu-math-4.2.3-1.fc10.x86_64 (installed)
> gstreamer-plugins-ugly-0.10.10-2.fc10.x86_64 from installed has
> depsolving problems
>   --> Missing Dependency: libcdio.so.7(CDIO_7)(64bit) is needed by
> package gstreamer-plugins-ugly-0.10.10-2.fc10.x86_64 (installed)
> gstreamer-plugins-bad-0.10.9-1.fc10.x86_64 from installed has
> depsolving problems
>   --> Missing Dependency: libcrypto.so.7()(64bit) is needed by package
> gstreamer-plugins-bad-0.10.9-1.fc10.x86_64 (installed)
> gstreamer-plugins-bad-extras-0.10.9-1.fc10.x86_64 from installed has
> depsolving problems
>   --> Missing Dependency: libBPM.so.0()(64bit) is needed by package
> gstreamer-plugins-bad-extras-0.10.9-1.fc10.x86_64 (installed)
> PyKDE4-4.2.3-2.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: python(abi) = 2.5 is needed by package
> PyKDE4-4.2.3-2.fc10.x86_64 (installed)
> kdeedu-math-4.2.3-1.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libboost_python-mt.so.3()(64bit) is needed
> by package kdeedu-math-4.2.3-1.fc10.x86_64 (installed)
> PyKDE4-4.2.3-2.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libpython2.5.so.1.0()(64bit) is needed by
> package PyKDE4-4.2.3-2.fc10.x86_64 (installed)
> PyQt4-4.4.4-6.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libpython2.5.so.1.0()(64bit) is needed by
> package PyQt4-4.4.4-6.fc10.x86_64 (installed)
> kdeedu-marble-4.2.3-1.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libgps.so.17()(64bit) is needed by package
> kdeedu-marble-4.2.3-1.fc10.x86_64 (installed)
> sos-1.8-11.fc10.noarch from installed has depsolving problems
>   --> Missing Dependency: python(abi) = 2.5 is needed by package
> sos-1.8-11.fc10.noarch (installed)
> kdebindings-4.2.3-2.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libqscintilla2.so.4()(64bit) is needed by
> package kdebindings-4.2.3-2.fc10.x86_64 (installed)
> ntp-4.2.4p7-1.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libcrypto.so.7()(64bit) is needed by package
> ntp-4.2.4p7-1.fc10.x86_64 (installed)
> 7:kdegraphics-4.2.3-1.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libpoppler.so.3()(64bit) is needed by
> package 7:kdegraphics-4.2.3-1.fc10.x86_64 (installed)
> preupgrade-1.1.0-1.fc10.noarch from installed has depsolving problems
>   --> Missing Dependency: python(abi) = 2.5 is needed by package
> preupgrade-1.1.0-1.fc10.noarch (installed)
> 7:kdegraphics-4.2.3-1.fc10.x86_64 from installed has depsolving problems
>   --> Missing Dependency: libdjvulibre.so.15()(64bit) is needed by
> package 7:kdegraphics-4.2.3-1.fc10.x86_64 (installed)
> 
> If fedora.repo and fedora-updates.repo are OK a yum update should do the trick.
> 
> What does yum repolist give you? And yum update?
> 
> I'm gonna boot the rawhide grub option tomorrow and see what I get.

Hello Martín, thanks for your answer.

Well, as I have libssl.so.8 and libcrypto.so.8 installed, and KDE is
looking for libssl.so.7 and libcrypto.so.7, I decided to create the
symbolic links that KDE is looking for. I have the following:

/usr/lib/libssl.so.8: symbolic link to `libssl.so.0.9.8k'
/usr/lib/libcrypto.so.8: symbolic link to `libcrypto.so.0.9.8k'

so I have created the following symbolic links:

/usr/lib/libssl.so.7: symbolic link to `libssl.so.0.9.8k'
/usr/lib/libcrypto.so.7: symbolic link to `libcrypto.so.0.9.8k'

and with that now everything is working fine again.

Anyway, my 'yum repolist' is as follows:

[german centauri ~]$ yum repolist
Loaded plugins: fastestmirror, presto, refresh-packagekit
repo id                   repo name
status
adobe-linux-i386          Adobe Systems Incorporated
enabled:     17
fedora                    Fedora 11 - i386
enabled: 13,289
fusion                    Compiz Fusion repository
enabled:     42
google                    Google - i386
enabled:      2
livna                     rpm.livna.org for 11 - i386
enabled:      3
rpmfusion-free            RPM Fusion for Fedora 11 - Free
enabled:    566
rpmfusion-free-updates    RPM Fusion for Fedora 11 - Free - Updates
enabled:      0
rpmfusion-nonfree         RPM Fusion for Fedora 11 - Nonfree
enabled:    240
rpmfusion-nonfree-updates RPM Fusion for Fedora 11 - Nonfree - Upda
enabled:      0
skype                     Skype Repository
enabled:      1
updates                   Fedora 11 - i386 - Updates
enabled:  1,293
repolist: 15,453

-- 
Germán A. Racca
http://gracca.wordpress.com
http://tinyurl.com/SkyTux (Linux user #490483)
Instituto Nacional de Pesquisas Espaciais - INPE
Divisão de Astrofísica - DAS/CEA
São José dos Campos - SP - Brasil
TEL: +55-12-3945-7151
FAX: +55-12-3945-6811


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]