[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Virtual Box install problem on FC10



yum install akmod-VirtualBox-OSE works... well, it installs all the packages and when I reboot does stuff.

Running VirtualBox I had an error message, so I tried as root and got the following

--------------------

WARNING: The vboxdrv kernel module is not loaded. Either there is no module
         available for the current kernel (2.6.27.24-170.2.68.fc10.i686.PAE) or it failed to
         load. Reboot the computer, or insert the kernel module by executing

           '/sbin/modprobe vboxdrv' (as root)

         You will not be able to start VMs until this problem is fixed.
Qt WARNING: QGtkStyle cannot be used together with the GTK_Qt engine.
Qt WARNING: Qt: Session management error: None of the authentication protocols specified are supported

------------

I ran /sbin/modprobe vboxdrv with no error...

when I run VirtualBox from commandline or from the icon I get an error screen

-----------
Caption:

Failed to create the VirtualBox COM Object

The application will now terminate

Could not load the settings file '/home/yoram/.VirtualBox/VirtualBox.xml'.

Cannot convert settings from version '1.7-linux'.

The source version is not supported.

Result Code:

VBOX_E_XML_ERROR (0x80BB000A)

Component:

VirtualBox

Interface:

IVirtualBox {339abca2-f47a-4302-87f5-7bc324e6bbde}


---------

Same thing with or without root.

What's the deal?

Thanks

2009/6/8 Sharpe, Sam J <sam sharpe+lists redhat gmail com>
2009/6/8 Yoram Halberstam <yoram halberstam gmail com>:
> ok, was missing akmods and other bits. I did yum install akmods (woo-oo I'm
> getting the hang of linux) and got a whole bunch of stuff with it...
>
>
>
> rpm -ivh /home/yoram/Download/akmod-VirtualBox-OSE-2.1.4-2.fc10.i686.rpm
>
> error: Failed dependencies:
>     VirtualBox-OSE-kmod-common >= 2.1.4 is needed by
> akmod-VirtualBox-OSE-2.1.4-2.fc10.i686
>     VirtualBox-OSE-kmodsrc = 2.1.4 is needed by
> akmod-VirtualBox-OSE-2.1.4-2.fc10.i686

The latter is http://download1.rpmfusion.org/free/fedora/updates/10/i386/VirtualBox-OSE-kmodsrc-2.1.4-4.fc10.i386.rpm
The former, I have no idea.

Have you tried simply "yum --enable-repo=* install
akmod-VirtualBox-OSE" ?? That should let Yum do all the depency
resolution for you...



--
Yoram Halberstam
Computer Services Provider
MSN: netfever hotmail com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]