[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Virtual Box install problem on FC10



it says:

vboxdrv                93896  0

Ok, if I need to go back to square one (the 4th email of this chain)... I compiled the stuff and then I had

Failed to start the virtual machine Kids.

VirtualBox can't operate in VMX root mode. Please disable the KVM kernel extension, recompile your kernel and reboot (VERR_VMX_IN_VMX_ROOT_MODE).


Result Code:

NS_ERROR_FAILURE (0x80004005)

Component:

Console

Interface:

IConsole {9511bc54-15ee-4ddf-808e-472aba03809c}


How do I compile my kernel without this KVM kernel extension and what is the side effects of doing so?

Cheers

2009/6/8 Sharpe, Sam J <sam sharpe+lists redhat gmail com>
2009/6/8 Yoram Halberstam <yoram halberstam gmail com>:
> yum install akmod-VirtualBox-OSE works... well, it installs all the packages
> and when I reboot does stuff.
>
> Running VirtualBox I had an error message, so I tried as root and got the
> following
>
> --------------------
>
> WARNING: The vboxdrv kernel module is not loaded. Either there is no module
>          available for the current kernel (2.6.27.24-170.2.68.fc10.i686.PAE)
> or it failed to
>          load. Reboot the computer, or insert the kernel module by executing
>
>            '/sbin/modprobe vboxdrv' (as root)
>
>          You will not be able to start VMs until this problem is fixed.
> Qt WARNING: QGtkStyle cannot be used together with the GTK_Qt engine.
> Qt WARNING: Qt: Session management error: None of the authentication
> protocols specified are supported
>
> ------------
>
> I ran /sbin/modprobe vboxdrv with no error...
>
> when I run VirtualBox from commandline or from the icon I get an error
> screen
>
> -----------
> Caption:
>
> Failed to create the VirtualBox COM Object
>
> The application will now terminate
>
> Could not load the settings file '/home/yoram/.VirtualBox/VirtualBox.xml'.
>
> Cannot convert settings from version '1.7-linux'.
>
> The source version is not supported.
>
> Result Code:
>
> VBOX_E_XML_ERROR (0x80BB000A)
>
> Component:
>
> VirtualBox
>
> Interface:
>
> IVirtualBox {339abca2-f47a-4302-87f5-7bc324e6bbde}
>
> ---------
>
> Same thing with or without root.
>
> What's the deal?

Alas, while I can help you with sensible suggestions for installing
VirtualBox - I've never used it so I can't comment on anything the
application spits out...

Just one question - what does "/sbin/lsmod | grep vboxdrv" say? (this
is just to check that the VirtualBox kernel module *is* actually
loaded - that's about as far as I can go)



--
Yoram Halberstam
Computer Services Provider
MSN: netfever hotmail com

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]