[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Sound not working after installation

Seems like others are hitting the same problem with the HDA-Intel related hardware.  More information has been uploaded to the bugzilla.

-- Robin

On Tue, Jun 9, 2009 at 10:12 AM, Robin Price II <robinprice gmail com> wrote:

I am having issues getting my sound to work in Fedora 11. 
I have been having issues since F8 when pulseaudio was introduced. 
I have filed the following bug:

I am not a sound expert and have not done much troubleshooting on sound issues so this is a little new for me. 
I do know in F8 if I 'yum remove pulseaudio' my sound would work. 
I don't want to do this in F11 since that is not going forward with newer technology and is only working around the problem.

What I would like is for someone to help me in the bugzilla on getting this fixed so that it works "out of the box" and tweaking is not necessary. 
Here is the information from the bz:

Description of problem:

Alienware m15x:

Sound is not working after the installation of Fedora 11 Beta.
Sound works correctly after the installation of the latest Ubuntu

Version-Release number of selected component (if applicable):

[wade laptop /]$ rpm -q pulseaudio

How reproducible:

Steps to Reproduce:
1. Install Fedora 11 Beta or below. (Fedora 8 works)
2. Play OGG file(s) or Flash based web video.

Actual results:
Sound is not working.

Expected results:
Sound to "work out of the box" and not needing any tweaking.

Additional info:

I apologize for any information I don't include in the initial opening of this
bugzilla. This is my first time tracking down a sound issue.



[wade laptop /]$ cat /proc/asound/cards
0 [Intel ]: HDA-Intel - HDA Intel
HDA Intel at 0xf0600000 irq 22

[wade laptop /]$ lsmod | grep snd
snd_hda_codec_realtek 265044 1
snd_hda_intel 29176 2
snd_hda_codec 65376 2 snd_hda_codec_realtek,snd_hda_intel
snd_hwdep 8600 1 snd_hda_codec
snd_pcm 79992 2 snd_hda_intel,snd_hda_codec
snd_timer 22496 1 snd_pcm
snd 65096 10
soundcore 7024 1 snd
snd_page_alloc 9216 2 snd_hda_intel,snd_pcm
[wade laptop /]$ lsmod | grep -c snd

[wade laptop /]$ lspci | grep Audio
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio
Controller (rev 03)

[wade laptop /]$ alsamixer -c 0
This shows all underlying devices not muted and turned up.

[wade laptop /]$ pavucontrol
This shows all devices listed not muted. I have tried different sound options.

Looks like I'm able to get sound if I do the following:

In the /etc/modprobe.d/sound file, I added:

options snd_hda_intel model=mbp3

Rebooted and sound worked. However, the argument is that sound _should_ be
working out of the box / after installation.

Also the output of alsa-info.sh is attached to the bz as well.
Can anyone let me know why it doesn't work after installation or what to look for while troubleshooting sound? 

Thanks in advance!

-- Robin

ninjaedit:  Congrats on F11 everyone!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]