[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 10 -> 11 Update Problem



On Wed, 10 Jun 2009 08:41:27 +0200, Michael wrote:

> On Wed, 10 Jun 2009 08:17:06 +0200 (CEST), Gerhard wrote:
> 
> > Hello,
> > 
> > I'm having some update problems:
> > rpm -Uhv http://download.fedora.redhat.com/pub/fedora/linux/releases/11/Fedora/i386/os/Packages/fedora-release-11-1.noarch.rpm
> > 
> > yum upgrade
> > 
> >    --> Missing Dependency: libcrypto.so.7 is needed by package 
> > ntp-4.2.4p7-1.fc10.i386 (installed)
> > glibc-2.9-3.i386 from installed has depsolving problems
> >    --> Missing Dependency: glibc-common = 2.9-3 is needed by package 
> > glibc-2.9-3.i386 (installed)
> > Error: Missing Dependency: glibc-common = 2.9-3 is needed by package 
> > glibc-2.9-3.i386 (installed)
> > Error: Missing Dependency: libcrypto.so.7 is needed by package 
> > ntp-4.2.4p7-1.fc10.i386 (installed)
> 
> What set of repositories is enabled?  yum repolist
> 
> The fact that yum doesn't see the fc11 ntp package or the fc11 glibc, for
> example, smells like you're missing the "fedora" repository (aka
> releases/11/Everything).

On the other hand, with regard to ntp, ntp-4.2.4p7-1.fc11 isn't tagged for
dist-f11, but only ntp-4.2.4p6-4.fc11 which is older than f10 updates'
ntp.  So, as this violates the upgrade path, f11 updates-testing is needed
for the newer ntp-4.2.4p7-2.fc11 - you should still see the much newer
glibc for f11, though, in the "fedora" repo.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]