[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

RE: Wireless networking - should I install Ralink driver? Solved



Frank Millman wrote:
> 
> Kevin Kofler wrote:
> > 
> > Frank Millman wrote:
> > > My next step was going to be to install the Ralink driver 
> > downloaded from
> > > their site, but I thought I would check here first to see 
> > if there are any
> > > other suggestions.
> > 
> > The driver from the Ralink site is legacy, I'm not even sure 
> > they still
> > update it at all, given that the rewritten driver from the 
> > rt2x00 project
> > (which is what you're getting by default) is now in the 
> kernel itself.
> > 
> 
> Thanks for the info, Kevin. I am glad I checked here first.
> 
> Does anyone have any other suggestions? To recap, here is the 
> problem again.
> 
> On startup, the card does not always initialise first time. 
> It appears to
> bring up wlan0 successfully, and it appears to
> start wpa_supplicant successfully. However, the next step is 
> to mount an NFS
> share. Sometimes it works first time, but usually it sits 
> there for a while
> and then fails. If I then check iwconfig, it shows no Access 
> Points, and 0
> for Link Quality. I then run 'service network restart' and 'service
> wpa_supplicant restart' a couple of times, and it usually 
> comes up on the
> second or third attempt.
> 

I read a message from Markus Kesaromous, on a related topic, that happened
to have the following line -

"I set scan_ssid=1 [in wpa_supplicant.conf] because my router does not
broadcast the ssid."

I have the same situation, so I have added that line to my .conf file, and
it seems to have solved the problem.

Thanks, Markus ;-)

Frank


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]