[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

F11 NFS4 idmapd Problem



Hi

Has anyone had a problem with F11 x86_64 and nfs4 mounts?

I run a Centos 5.3 nfs server which is working
fine using nfs4 with a fully updated F10 machine 

I installed F11 yesterday on a second machine with full updates

On the F11 machine when I mount, either by hand, or autofs/NIS the
names/UIDs Groups/GID are not mapped

I cannot see any obvious differences between the two machines (F10/F11)

mount -t nfs4 148.197.29.5:/global /mnt/zip

ls -l /mnt/zip
total 19787316
drwxr-xr-x 10 nobody nobody        4096 2009-06-10 09:42 cdrw
drwxrwxrwx 12 nobody nobody        4096 2009-03-13 09:38 db
drwxr-xr-x  4 nobody nobody        4096 2008-12-09 18:13 from_maui_april_2006
drwxr-xr-x  3 nobody nobody        4096 2008-12-09 18:24 local_maui
drwx------  2 nobody nobody        4096 2008-12-09 18:24 lost+found

cat /var/log/messages shows
Jun 11 12:13:32 monk rpc.idmapd[5938]: nss_getpwnam: name 'root localdomain' does not map into domain 'jaa.org.uk'
Jun 11 12:13:51 monk rpc.idmapd[5938]: nss_getpwnam: name 'ja localdomain' does not map into domain 'jaa.org.uk'


The right things seem to be running on both machines
F11
[root monk ~]# ps -ef|grep -i rpc
rpc       1390     1  0 10:48 ?        00:00:00 rpcbind
rpcuser   1403     1  0 10:48 ?        00:00:00 rpc.statd
root      1434     2  0 10:48 ?        00:00:00 [rpciod/0]
root      1435     2  0 10:48 ?        00:00:00 [rpciod/1]
root      5938     1  0 11:34 ?        00:00:00 rpc.idmapd

F10
pagham ~ 13# ps -ef|grep -i rpc
rpc       2187     1  0 Jun08 ?        00:00:00 rpcbind
rpcuser   2200     1  0 Jun08 ?        00:00:00 rpc.statd
root      2232     2  0 Jun08 ?        00:00:00 [rpciod/0]
root      2233     2  0 Jun08 ?        00:00:00 [rpciod/1]
root      2234     2  0 Jun08 ?        00:00:00 [rpciod/2]
root      2235     2  0 Jun08 ?        00:00:45 [rpciod/3]
root      2242     1  0 Jun08 ?        00:00:00 rpc.idmapd
------------------------------------------------------------------
A "normal" nfs mount works fine
mount  148.197.29.5:/exports/global /mnt/zip
ls -l /mnt/zip
total 19787316
drwxr-xr-x 10 root root            4096 2009-06-10 09:42 cdrw
drwxrwxrwx 12 ja   sysadmin        4096 2009-03-13 09:38 db
drwxr-xr-x  4 root root            4096 2008-12-09 18:13 from_maui_april_2006
drwxr-xr-x  3 root root            4096 2008-12-09 18:24 local_maui
drwx------  2 root root            4096 2008-12-09 18:24 lost+found


Hopefully I am missing something obvious

John



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]