[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Yum proxy authentication problem in F11



Hi all,

I tried to upgrade my F10 box to F11 with the preupgrade utility.

Anything seemed to go right but since my machine is screenless, I could
control through a ssh client all the preupgrade process. At this time no
error message were displayed. Then, I could not check whether error
message were printed or not after I rebooted to launch the real upgrade
process.

Nontheless, anything seemed to go right. After awhile, the PC rebooted
and was working again except I can't launch yum anymore.

The reason is that it can't authenticate through the proxy as it did
before.

Here is what I attempted to do so?

First, I tried to do it as I was used to in F9 and F10. In other words,
I created an environment variable named http_proxy by the following bash
command:

export http_proxy=http://myname:mypassword theproxy:theport

I tried then the following command:

yum -d 10 -e 10 -v -y upgrade

As a reponse, I got the following messages:

-------------------
Not loading "blacklist" plugin, as it is disabled
Loading "dellsysidplugin2" plugin
Loading "refresh-packagekit" plugin
Not loading "whiteout" plugin, as it is disabled
Config time: 5.301
Yum Version: 3.2.23
Setting up Package Sacks
------------------

Then, yum seemed to be hung.

Then, I tried several attempts to put the proxy information in
/etc/yum.conf. By doing this, yum did not hang anymore but always
returned the following message:

-----------
Error: Cannot retrieve repository metadata (repomd.xml) for repository:
fedora. Please verify its path and try again
--------------

So, here is my question:

What is the exact syntax to let yum perform a so-called "basic
authentication" through an HTTP proxy?

Many thanks. Have a nice day. ChD


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]