[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: **PANIC** failed to recognize the Operating system



On Fri, 12 Jun 2009 10:40:57 +0200, roland <roland cat be> wrote:

I think I have a big problem

When I try to install something I get the message
failed to recognize the Operating system you ar using

When I type
uname -a
I get the message
segmentation fault

Consequences:
I cannot install anything anymore
and
the VMware clients do not start anymore

Can anybody please..please..please help me?


I did a
strace grep
and it resultat in

execve("/bin/grep", ["grep"], [/* 37 vars */]) = 0
brk(0)                                  = 0x879a000
access("/etc/ld.so.preload", R_OK) = -1 ENOENT (No such file or directory)
open("/etc/ld.so.cache", O_RDONLY)      = 3
fstat64(3, {st_mode=S_IFREG|0644, st_size=77806, ...}) = 0
mmap2(NULL, 77806, PROT_READ, MAP_PRIVATE, 3, 0) = 0xb7fb1000
close(3)                                = 0
open("/lib/libpcre.so.0", O_RDONLY)     = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0\20\237Z\0074\0\0\0"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=118896, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7fb0000 mmap2(0x75a9000, 116176, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x75a9000 mmap2(0x75c5000, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x1c) = 0x75c5000
close(3)                                = 0
open("/lib/libc.so.6", O_RDONLY)        = 3
read(3, "\177ELF\1\1\1\0\0\0\0\0\0\0\0\0\3\0\3\0\1\0\0\0000_\1\0004\0\0\0"..., 512) = 512
fstat64(3, {st_mode=S_IFREG|0755, st_size=1598904, ...}) = 0
mmap2(NULL, 1320356, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 3, 0) = 0x158000 mmap2(0x295000, 12288, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 3, 0x13d) = 0x295000 mmap2(0x298000, 9636, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_ANONYMOUS, -1, 0) = 0x298000
close(3)                                = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0xb7faf000 set_thread_area({entry_number:-1 -> 6, base_addr:0xb7faf6c0, limit:1048575, seg_32bit:1, contents:0, read_exec_only:0, limit_in_pages:1, seg_not_present:0, useable:1}) = 0
mprotect(0x295000, 8192, PROT_READ)     = 0
mprotect(0xd47000, 4096, PROT_READ)     = 0
munmap(0xb7fb1000, 77806)               = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV +++

Is thre anybody who understands this?


Roland


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]