[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Not Authorized error adding printer





On Thu, Jun 11, 2009 at 21:06, Michael D. Setzer II <mikes kuentos guam net> wrote:
I've tried using system-config-printer and I can connect to the IPP server,
and see the queues and select the printer, but at the end to add printer it
fails with an not authorized message. Tried running it via a regular user
command line and from a root command line. Same error.

This is what the command line shows, thou the gui shows no error other than
the not authorized.

Caught non-fatal exception.  Traceback:
File "/usr/share/system-config-printer/system-config-printer.py", line 4137, in
nextNPTab
   encryption=encryption)
RuntimeError: httpConnectionEncrypt failed
Continuing anyway..

Tried adding the printer by using the jetdirect option, but it also ends with a
not authorized message, but nothing shows on the command line.

I was finally able to get the printer added but using the browser on the
machine to connect to 127.0.0.1:631 and go thru the process to add the
same IPP printer. It then showed up in the system-config-printer list. So, not
sure what is going on??


I can't help, but want to say I have the same problem.

I run system-config-printer on the F11 system after using "su -" to get root access. (Clean install of F11)
I can go all the way through selecting the proper printer driver and then I get the "unauthorized" error.

Also, and per haps related?) is I can not log on as root on that machine. I can use "su -" to get root access, but I can not log on as root. I get an error saying unable to authorize...



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]