[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Grub doesn't recognize hdd in F11 x86_64



2009/6/3 Marcin Wołyniak <marcin_wolyniak aster pl>:
> Dnia Wolfgang S. Rupprecht 03.06.2009 19:08 napisał(a):
>> >
>> > Might it be this problem?  Do you have more than one disk in the system?
>> >
>> > https://www.redhat.com/archives/fedora-test-list/2009-May/msg01392.html
>> >
>> > You might just need to do a "grub-install".
>> >
>> > -wolfgang
> Unfortunately this is laptop and has only one disk.
> I forgot mention that more details what I tried are in the bugzilla
> under the link mentioned in first post.
>
> I've already done the grub-install with no success. More, I've  then
> lost the grub console after reboot. Only Error 21 message displayed with
> no console.

Hi.  Any progress on this?

This may be completely unrelated to your issue.  I was unable to boot
F11-Preview or F11-Release (both x86_64).  I installed multiple times.
 I installed grub to NON-MBR (sda8).  I tried re-installing grub to no
effect.

This morning I booted linux rescue mode, and ran 'fdisk' on the disk.
I realized that my Fedora 11 X86_64 installation somehow mislabeled
the partition id for '/' sda8 as ID=6 (FAT16) instead of ID=83
(LINUX).

I changed the ID to 83, and re-installed grub and now Fedora 11 64
boots correctly!

Oddly enough this only happened on my T61 Laptop, but did not happen
on my AMD64 Desktop.  Both systems I installed F11-64 and grub to
non-MBR and both I chainloaded through Vista/XP.

I am looking through bugzilla to see if this was already reported.

-Mauriat


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]