[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: ti_usb_3410_5052: probe of 3-2:1.0 failed with error -5 ??



Gregory Machin wrote:
Hi
I have a  Huawei device that I have been using on fc 8 and fc 10. But
now with fc 11 it does not work.

Here is the log file entries for the device.
Jun 13 15:42:25 localhost kernel: usb 3-2: USB disconnect, address 26
Jun 13 15:42:25 localhost kernel: usb 3-2: new full speed USB device
using uhci_hcd and address 27
Jun 13 15:42:25 localhost kernel: usb 3-2: New USB device found,
idVendor=0451, idProduct=3410
Jun 13 15:42:25 localhost kernel: usb 3-2: New USB device strings:
Mfr=1, Product=2, SerialNumber=3
Jun 13 15:42:25 localhost kernel: usb 3-2: Product: TUSB3410 Boot Device
Jun 13 15:42:25 localhost kernel: usb 3-2: Manufacturer: Texas Instruments
Jun 13 15:42:25 localhost kernel: usb 3-2: SerialNumber: TUSB3410
Jun 13 15:42:25 localhost kernel: usb 3-2: configuration #1 chosen
from 2 choices
Jun 13 15:42:25 localhost kernel: ti_usb_3410_5052 3-2:1.0: TI USB
3410 1 port adapter converter detected
Jun 13 15:42:25 localhost kernel: ti_usb_3410_5052: probe of 3-2:1.0
failed with error -5<<<<<<<<<<<<<<
Jun 13 15:42:25 localhost kernel: ti_usb_3410_5052 3-2:2.0: TI USB
3410 1 port adapter converter detected
Jun 13 15:42:25 localhost kernel: usb 3-2: TI USB 3410 1 port adapter
converter now attached to ttyUSB0
Jun 13 15:42:25 localhost NetworkManager:<info>   (ttyUSB0): ignoring
due to lack of mobile broadband capabilties

I have resolved this before by doing the following

create /etc/udev/rules.d/026_ti_usb_3410.rules

#TI USB 3410
SUBSYSTEM=="usb_device" ACTION=="add"
SYSFS{idVendor}=="0451",SYSFS{idProduct}=="3410" \
SYSFS{bNumConfigurations}=="2" \
SYSFS{bConfigurationValue}=="1" \
RUN+="/bin/sh -c 'echo 2>  /sys%p/device/bConfigurationValue'"

I have coppied /lib/firmware/ti_3410.fw to /lib/firmware/ti_3410.bin
this fixed it on fc 10

I have coppied /lib/udev/rules.d/77-nm-probe-modem-capabilities.rules
to  /etc/udev/rules.d/

Now I'm out of ideas please could someone advise ?

Thanks

your udev rule is different then whao worked for me, I did not need to specify idVendor and idProduct details

SUBSYSTEM=="usb" , ACTION=="add" , \
ATTR{product}=="MSPāˆ’FET430UIF JTAG Tool" , \
ATTR{bNumConfigurations}=="2" , ATTR{ bConfigurationValue}="2"


Depending on your kernel Rob stated Fedora 11 should have an already patched kernel, see blog http://xgoat.com/wp/2009/03/29/fet430-firmware-already-fixed/ My paper http://www.toshaan.be/publications/cybernetics/Programming_report.pdf , states everything, currently don't have the JTAG here, so I cannot test it myself anymore


--
Toshaan <toshlinux gmail com> - http://www.toshaan.be


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]