[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Fedora 10->11 Preupgrade Failure. Franken-system.



Kevin Bowling wrote:
> Hello,
> 
> I have an IBM x3650 that was running F10.  I initiated preupgrade-cli
> for F11, which downloaded packages and rebooted the box.  Preupgrade
> came up in GUI mode, but for whatever reason the Radeon R100 card was
> excruciatingly slow and this somehow affected the speed of installing
> packages.  It took nearly 16 HOURS for the upgrade packages to install
> (99.999% CPU idle, barely any disk activity) -- keep in mind this is an
> 8 core server and is connected to a high-speed RAID-6 storage system.
> 
> After the ~1800 of ~1800 packages were installed, it opened the "Please
> wait while setup is finished.  This may take a while" dialog.  This sat
> for 24 HOURS without completing.  At this point, I rebooted the machine
> because this is a quasi-production QA box and I had people that needed
> access to it.
> 
> The upgrade seemingly went well despite, and it booted up.  However
> there are some particularities.  Yum lists both the F10 and F11 packages
> as installed.  One area that seemed to be affected is Java/Eclipse.  It
> is much slower than it should/used to be.
> 
> There are two problems here:
> 1) KMS or DRM, or most likely the radeon video driver are faulty.  The
> textmode framebuffer worked at full speed.  Further, why does
> preupgrade-cli even start Xwindows?  Why would the speed of X determine
> how fast Anaconda ran background tasks?  There was nothing interesting
> in the upgrade logs, dmesg, etc :-(.
> 
> 2) I now have a franken-system that seemingly has both F10 and F11
> versions of packages installed.  How can I manually clean this up?
> 
> Regards,
> Kevin
> 

I couldn't even get started as the preupgrade reboot to install couldn't figure
out my laptop screen. I had a garbled mess which was the same with the install
DVD on upgrade, and it's a standard HP 15.4 laptop screen. I unison all my data
with my desktop, so I did a clean install with new partitions using the basic
video driver instead of looking to see if I could do a command work around.
That worked, but took a bit more tweaking afterwards, but I thought I'd try
ext4 which seems snappier. The graphical boot required some grub file editing
to get working. Also, I had to configure my touchpad for taps to work as a
mouse click which is still off in the login screen. Overall, seems like a
rushed roll out with some annoying issues still in the mix.

I should add that I'm overall liking Fedora 11 to where I'm not ready to switch
distros on the laptop. But then Fedora 11 is no where close to having me
replace Slackware 12.2 on my desktop system.

-- 
Jason Turning


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]