[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Baffled by a Cable Modem



Here is a continuation of my efforts. I really appreciate the help.

----------------------------------------------------------------------------

>Patrick wrote:
> Did you try another browser to see if it works with the other sites?

I installed and tried Dillo. It said "Query sent Waiting for reply"

----------------------------------------------------------------------------

> Rick Stevens wrote

> Here's one way to troubleshoot it:

> Using FireFox, see if you can get to the cable modem's GUI interface.
> Most of them will have one of the following four IPs as their default:

>     192.168.0.1
>    192.168.0.254
>    192.168.1.1
>    192.168.1.254

tried all of those with no luck

> The first thing you should do is make sure your NIC can access all of
> those addresses without using a gateway.  As root in a console:

>    ifconfig eth0 192.168.0.128 netmask 255.255.0.0

>  This puts your computer on the class B (CIDR /16) network of 192.168.0.0
> and you should be able to hit any of the above four addresses directly
> (in fact, any IP from 192.168.0.1 through 192.168.255.254).

>Next, try "http://192.168.0.1" and see if you get the modem's GUI.  If
> you don't, try the other three IPs above.  If it's none of those, check
> the manual for the modem and see what the default LAN IP is.  Make sure
> you get the LAN IP, _NOT_ the WAN IP (anything on the WAN side is the
> cable company's side of the connection).

tried all the above, with no luck. The manual does not mention a "LAN IP" that I can find. It does not mention a GUI.

> If you can browse the IP, then you know that at least your machine and
> your modem can communicate.  Wander through the modem's user interface
> looking for its DHCP server settings.  Make sure the DHCP server is
> enabled and take note of which addresses it will offer (usually called
> the "pool").


> At this point, you should be able to have the modem give you an IP.
>Make sure your system is set up to fetch an IP address via DHCP and
> either reboot your system, restart NetworkManager (if you use it):

>     service NetworkManager restart


> Once that's all done, again as root in a console, do:

>    ifconfig eth0

> and verify it has an IP address that's in the range described by the
> pool data you got before.  If that's all good, do:
>   netstat -rn

It returned "Forwarding is ON or its state is unknown (5). OK, No RDISC.
Missing IP address argument."



it returned:
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.122.0   0.0.0.0         255.255.255.0   U         0 0          0 virbr0

> and verify that the line that contains the flags "UG" is the same
> IP as the cable modem.  Example:

>     0.0.0.0   192.168.1.254   0.0.0.0    UG  0 0    0 eth0
>              ^^^^^^^^^^^^^
>              IP of cable modem

> If all that checks out, then you SHOULD have a live connection to the
> Internet.  The last thing to check is your /etc/resolv.conf file and
> ensure that the "nameserver" lines have legitimate IP addresses for
> live DNS servers.  This should be set up when the DHCP server gives you
> the IP address and default route, but not always.  If it doesn't set
> this up, you could manually add entries.  Here's a couple of entries you
> can use:

>    nameserver 208.67.222.222
>    nameserver 208.67.220.220

 I tried adding those to the top of the list of nameservers,  and restarted firefox - no change . I then rebooted and they sre gone from resolv.conf again.

Hope that helps a bit.
----------------------------------------------------------------------
- Rick Stevens, Systems Engineer                      ricks nerd com -
- AIM/Skype: therps2        ICQ: 22643734            Yahoo: origrps2 -
-                                                                    -
-         Microsoft Windows:  Proof that P.T. Barnum was right       -
----------------------------------------------------------------------


I am still stuck. I seem to have a dedicated Google machine. I can check my mail at gmail.com, including loading messages ( I haven't tried to send one yet) The google search in Firefox works fine. GoogleEarth wiorks well -- and I still can't reach any other sites: And it all works fairly well in Windows XP ( it is still Windows!  winipcfg doesn't work. There is a screwed up .dll, apparently )
It seems to me that it might be in the nameserver somewhere. I suspect the modem maker did something odd in the driver and furnished it to Microsoft and won't release it now. I saw that the USBnet programmers do not have a driver for this modem.
 How can it work OK with google and have a configuration problem in my setup?

------------------------------


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]