[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

OT Qwest dsl gotchas for linux, F10 x86_64



I just switched from Cox cable to Qwest dsl.  Price was cheaper, and
qwest is talking 40 mbit/sec speeds in the next few months.  Keep that
up and soon we'll be at half the speed of the leading internet
countries. (100 mbit/sec) :-)

Qwest makes no secret of the fact they do not support linux, and there
were some issues that cost me several hours to resolve because of
that. Several times I just about chucked in the towel and reactivated
my cox broadband (30 day switch option, total cost $10 or $15).  I
thought I would post the solutions I found here for anyone who might
make the switch.

First, dsl uses pppoe so you need a userid and password to access the
internet, unlike cable. And if you use a router behind your modem,
you will need to switch it from dhcp to pppoe and put in the userid
and password of the pppoe connection.  When you get the dsl modem, it
will come with a userid and password already installed, and they will
seem to work, as the modem will have an ip address assigned to it.  You
will even be able to ping out.  But the *real* userid and password are
embedded in the bundled windows software.  You will need to call user
support to get them. They send several sheets with connect codes, seems
it would be easy for them to add this.  Go figure.

Second, qwest uses windows live as their email provider.  And while
tech support will give you the pop3 server, pop3.live.com, and the
protocols, port 995 via ssl, they don't tell you that the username
at windows live *includes* the domain name.  So if your address is
somebody q com, that is also your username, not just the somebody.
The pop3 has to be authenticated with the username and the password for
that username. Every linux client I tried could do this (seamonkey,
thunderbird, sylpheed, claws).  The account name has an extra domain on
the end though.  :-o

Third, their tech support will tell you that the smtp server,
smtp.live.com uses port 25 and ssl.  Unfortunately, that is not true.
They use a combination of TSL and ssl.  The only client that I tried
that could do this was claws.  I set the smtp authenticate, leaving the
userid and password blank so that it would use the pop3 userid and
password.  And I set the option to use starttls and ssl.  I did not try
evolution, perhaps it would have worked out of the box with its greater
windows compatibility.  When I called asking about what they were doing
with their server that was causing the problem, they said it was a
client problem, and basically told me tough luck.  Typical microsoft,
"Standard? We *are* the standard!".  They have some justification for
that view, but just some.  ;-)

Hope this saves someone a few hours of grief.  

This whole incident has me looking into email hosting and private
domain names.  Both are very cheap right now.  Hosting using someone
else's domain can be had for $10 US and up per year, hosting with your
own domain about $23 and up per year, and domain and web hosting for
$42 and up per year.  Seems the way to go.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]