[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

s-c-p: stupid app or PolicyKit annoyance?



I run system-config-printer as root, and it either hangs
forever or tells me I'm not authorized when I want to do
something like change printer default options.

I run system-config-printer as normal user and it asks
me to give the root password every few seconds (for
example, try deleting a printer, then clicking
on New to reinstall it from scratch).

Do I have to not only be root but also tell PolicyKit
that root is allowed root access? Is there a
global way to cram that down PolicyKit's throat?

Or does this have nothing to do with PolicyKit
and system-config-printer is merely the most annoying
app ever written when it comes to asking for
root auth?

Or perhaps there are another dozen gnome background
clutter daemons I have to run for apps to remember
I know the root password?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]