[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: s-c-p: stupid app or PolicyKit annoyance?



On Wed, Jun 17, 2009 at 2:24 PM, Tom Horsley<tom horsley att net> wrote:
> I run system-config-printer as root, and it either hangs
> forever or tells me I'm not authorized when I want to do
> something like change printer default options.
>
> I run system-config-printer as normal user and it asks
> me to give the root password every few seconds (for
> example, try deleting a printer, then clicking
> on New to reinstall it from scratch).
>
> Do I have to not only be root but also tell PolicyKit
> that root is allowed root access? Is there a
> global way to cram that down PolicyKit's throat?
>
> Or does this have nothing to do with PolicyKit
> and system-config-printer is merely the most annoying
> app ever written when it comes to asking for
> root auth?
>
> Or perhaps there are another dozen gnome background
> clutter daemons I have to run for apps to remember
> I know the root password?

F11 is full of new annoyances. Have you checked the firewall settings
since you installed F11?

Among my peeves:

1. If you change SELinux to permissive mode to troubleshoot a problem
you're constantly inundated with AVC violations notices. (Someone is
really trying to drive Fedora users over to Ubuntu or OpenSUSE.)

2. Pulseaudio no longer works in the F11 client under Vmware. Removal
of system-config-soundcard without a equivalent tool replacement adds
salt to the wound.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]