[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: s-c-p: stupid app or PolicyKit annoyance?



On Wed, 2009-06-17 at 18:24 -0400, Tom Horsley wrote:
> I run system-config-printer as root, and it either hangs
> forever or tells me I'm not authorized when I want to do
> something like change printer default options.

This is due to PolicyKit:
https://bugzilla.redhat.com/show_bug.cgi?id=447266

> I run system-config-printer as normal user and it asks
> me to give the root password every few seconds (for
> example, try deleting a printer, then clicking
> on New to reinstall it from scratch).

Most operations go through PolicyKit; however, clicking on New requires
fetching the list of available devices, an operation that previous
versions of CUPS had allowed without authentication.  There is no
PolicyKit action to fetch available devices provided by cups-pk-helper,
so this operation falls back to the IPP method and prompts you for a
password.

Here's the open bug against cups-pk-helper that tracks that issue:
https://bugzilla.redhat.com/show_bug.cgi?id=506513

> Or does this have nothing to do with PolicyKit
> and system-config-printer is merely the most annoying
> app ever written when it comes to asking for
> root auth?

Try removing cups-pk-helper. ;-)  This will cause system-config-printer
to use IPP authentication for everything.

Tim.
*/

Attachment: signature.asc
Description: This is a digitally signed message part


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]