[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Change Machine, No Sound (longish)

First, thanks for taking the time to read this. Sorry it's
longish, but I wanted to report what I've tried and what's
in there.

I use an old but working version of Fedora.

My motherboard recently fried its keyboard and video ports
for unknown reasons. I installed the discs into another machine,
booted up, and let kudzu do its thing. Only thing is, no sound.

# lspci
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)

That looks like a fairly common, if old, sound chip, and AC97
is a very common standard interface.

# modprobe -l | grep ac97

Ok, that first one looks like a possible winner.

# modprobe -c | grep ac97
alias symbol:snd_ac97_pcm_open snd_ac97_codec
alias symbol:snd_ac97_pcm_assign snd_ac97_codec
alias symbol:snd_ac97_update snd_ac97_codec

Ok, looks like it knows how to install it.

# modprobe -v --first-time snd_ac97_codec
FATAL: Module snd_ac97_codec already in kernel.

OOPS! Already there! Ok, so why no sound? Let's see what dmesg has to
say... the only thing which looks related is

# dmesg
via82xx: Assuming DXS channels with 48k fixed sample rate.
         Please try dxs_support=1 or dxs_support=4 option
         and report if it works on your machine.

Searching the web doesn't turn up anything about DXS channels,
which I don't know what they are. The only reason this looks
like it might be related is the "48k fixed sample rate", which
might be 48 kbps audio sampling rate or something like that.
Really, I see nothing there which looks like it found any audio
stuff at all.

Ok, what's actually there...

# lsmod
Module                  Size  Used by
sd_mod                 16705  0
snd_mixer_oss          17089  2
snd_via82xx            27745  3
snd_ac97_codec         67745  1 snd_via82xx
snd_pcm                93769  2 snd_via82xx,snd_ac97_codec
snd_timer              29381  1 snd_pcm
snd_page_alloc          9669  2 snd_via82xx,snd_pcm
gameport                5185  1 snd_via82xx
snd_mpu401_uart         9153  1 snd_via82xx
snd_rawmidi            26081  1 snd_mpu401_uart
snd_seq_device          8653  1 snd_rawmidi
snd 53797 10 snd_mixer_oss,snd_via82xx,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
soundcore              10273  3 snd
parport_pc             26629  1
lp                     12077  0
parport                37641  2 parport_pc,lp
autofs4                24005  0
sunrpc                158117  1
via_rhine              23625  0
mii                     4801  1 via_rhine
ipt_REJECT              6593  1
ipt_state               2113  8
ip_conntrack           40949  1 ipt_state
iptable_filter          3777  1
ip_tables              16577  3 ipt_REJECT,ipt_state,iptable_filter
floppy                 58097  0
sg                     34145  0
scsi_mod              123073  2 sd_mod,sg
microcode               6625  0
dm_mod                 56149  0
uhci_hcd               31705  0
ehci_hcd               35273  0
md5                     4161  1
ipv6                  237441  10
ext3                  121161  3
jbd                    71001  1 ext3

Ok, it looks like the via82xx driver is in there, which is
what lspci reports. I didn't trim that report, in case
I might cut something which might be related due to ignorance
or inadvertence.

However, trying to play something which used to work, like

$ mpg123 -v misty092700.mp3
High Performance MPEG 1.0/2.0/2.5 Audio Player for Layers 1, 2 and 3
        version 1.6.4; written and copyright by Michael Hipp and others
        free software (LGPL/GPL) without any warranty but with best wishes
Decoder: SSE

Playing MPEG stream 1 of 1: misty092700.mp3 ...
Title:   misty092700
MPEG 2.0, Layer: III, Freq: 16000, mode: Single-Channel, modext: 0, BPF : 108
Channels: 1, copyright: No, original: No, CRC: No, emphasis: 0.
Bitrate: 24 kbit/s Extension value: 0
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe Frame# 0 [271564], Time: 00:00.00 [162:56.30], RVA: off, Vol: 100(100)ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed: Broken pipe
Frame#    63 [271501], Time: 00:02.26 [162:54.03], RVA:   off, Vol: 100(100)

[HIT ^C]

[0:02] Decoding of misty092700.mp3 finished.

ALSA is complaining about a broken pipe. The player thinks it's sending
sound out, because the frame numbers are going up and up, but no sound,
and ALSA complains.

Searching for that error message "SNDRV_PCM_IOCTL_START failed"
turned up some suggestions to get a different version of ALSA,
suggesting an OLDER version. Hmm. Someone else suggested looking

$ ls -l .ICEauthority
-rw-------  1 jmccarty jmccarty 7251 Jun 18 23:56 .ICEauthority

Ok, I have r/w. So? They then suggest renaming that file to "get a clean
one". Huh? Sorry, I'm confused, and not going to start doing that kind
of stuff because someone who uses Mandriva suggests it.

Another said this can be caused by KDE automatically running arts.
I run GNOME anyway, but the setup hasn't changed in this respect
so I don't see the connection there.

I'm not an expert at these matters, and have reached my limit on
what to try next.

Anyone have any suggestions? I sure need some.

Oppose globalization and One World Governments like the UN.
This message made from 100% recycled bits.
You have found the bank of Larn.
I speak only for myself, and I am unanimous in that!

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]