[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Change Machine, No Sound (longish)



stan wrote:
On Fri, 19 Jun 2009 02:33:21 -0500
Mike McCarty <Mike McCarty sbcglobal net> wrote:

Thanks for the reply. I've downloaded, untarred, and am reading.
So far, I don't see anything, but there's a lot there.


Thanks for the reply.

You want to look in the directory alsa-kernel/Documentation.  That is
where all the driver documentation is.  Well, the real documentation is
in the source. ;-)

Yeah, I found both of those. Reading other people's code isn't
the most pleasant way to find out how stuff works.

Also, I note that /dev/dsp exists, but if I copy some file to it, no
sound comes out. I wonder if that's related.

In the latest kernels, OSS is considered obsolete and no longer
automatically installed.  You have to put the required modules into the
/etc/modules.conf file.  This will probably break a lot of old
applications.

I'm running an old kernel, but not that old. Not like 2.2 or 2.4.
I'm running a 2.6 kernel.

You are running old kernels for which this shouldn't apply, but it
might be relevant.

It is possible that your application is trying to use true oss and is
failing.  All current OSS is just alsa emulation, and so the modules to
do that have to be installed.

Why would that configuration change just because the discs
were moved to different hardware? The software configuration
worked before. It's just on different hardware.

[how to pass in parameters to modules? modules.conf or modules.d?]

Yes, in Fedora it would be /etc/modules.conf; in debian derivatives it
will be /etc/modules.d/alsa

I've run Fedora on here for quite a while, but also had to
administer a Debian machine, so sometimes things get a little
muddled after not having to do a certain thing for a few years.


[...]

You could also run the script below and post the link or run with
option (I think it is) --with-noupload and post the output so
people can see what your system configuration is.

http://www.alsa-project.org/alsa-info.sh
I ran that script, and captured the output, but it's nearly 800 lines
of stuff, and not suitable just to post. However, if anyone knows
how to interpret it, and can help, then I can subset out what is
useful. At least these parts seemed useful:

[snippy]

[more stuff listed but cut, anyway, it seems to have found it]

It shows all the sound modules that are loaded.  You can deduce from
that whether the OSS stuff is there or not.

ALSA is getting invoked, and then complaining it has a broken
pipe. I wonder why? I also tried running mpg123 with the specific
switch to force it to use ALSA interface, with no change.

The parts that are present seem to indicate that everything is
identified and functioning correctly.  No joy.

You see, that's the conclusion I was drawing: Everything I knew
to check looked like it had been loaded and initialized, but
still no sound.

I did also check the "taskbar" speaker volume, and it's not a
problem with muting the sytem.

I'm surprised that there is something that kudzu didn't figure out.

Mike
--
p="p=%c%s%c;main(){printf(p,34,p,34);}";main(){printf(p,34,p,34);}
Oppose globalization and One World Governments like the UN.
This message made from 100% recycled bits.
You have found the bank of Larn.
I speak only for myself, and I am unanimous in that!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]