[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Change Machine, No Sound (longish)



stan wrote:

Thanks for the reply again. I'm leaving for the weekend in just a bit,
so this will be my last message this week. However, I'll be back on
Monday, and I trow the sound card won't start working on its own. :-)

On Fri, 19 Jun 2009 10:07:21 -0500
I noticed that the card has a built-in modem.  It is possible that the
setup placed it as default instead of the sound device.  You could
check for that in /etc/modules.conf or with aplay -lLv  (I put all
three instead of remembering exact syntax) :-)

$ cat /etc/modules.conf
# I2C module options
alias char-major-89 i2c-dev
#options parport_pc io=0x378 irq=7 dma=3
options parport_pc io=0x378 irq=7

I don't see anything in there about sound cards at all.
Maybe I need to add another alias or something in there. I could try
pulling that file from a backup, and see what it used to look like.

The output of aplay was, to say the least, verbose, being 249 lines.
What part of it is significant?

And you might want to move /etc/asound.conf and ~/.asoundrc to backups
and try a reboot to see if they were influencing the sound detection in
any way.

$ ls /etc/asound.conf ~/.asoundrc
ls: /etc/asound.conf: No such file or directory
ls: /home/jmccarty/.asoundrc: No such file or directory

I went to my backup directory, where I keep tables of contents of my
backups, and looked.

[root Presario-1 backups]# grep asound[.]conf *.toc
[root Presario-1 backups]# grep asoundrc *.toc
yakup0.20080926.toc:usr/share/doc/alsa-lib-1.0.3a/asoundrc.txt

So, it's not just a matter of those files going away since the
machine change. They didn't exist before.

Maybe try after typing   esdctl off  . I noticed you had esd on, it
might have some interaction with alsa causing problems.

I tried that, but without a reboot. Still no joy. I wish ALSA would
tell me what pipe is broken.

All these are grasping at straws.  I'm as stumped as you are at this
point.

Well, I'm pretty stumped. I've checked the volume control on the
(amplified) speakers, and it's turned up, and they are turned on,
and they have power. I've tapped the plug from the speakers which
goes into the  output jack on the computer case, and I get good
loud clicks from the speakers. I've checked that the plug is inserted
into the correct jack, and is properly seated.

I've checked the BIOS to make sure tsound card is set as ENABLED
(it's actually part of the motherboard). I suspect if it weren't
ENABLED it wouldn't even be found, but it was worth checking.

Also, when the machine boots, the BIOS shoots one BEEP! out the
speakers, so I know it's _capable_ of making noise.

Mike
--
p="p=%c%s%c;main(){printf(p,34,p,34);}";main(){printf(p,34,p,34);}
Oppose globalization and One World Governments like the UN.
This message made from 100% recycled bits.
You have found the bank of Larn.
I speak only for myself, and I am unanimous in that!


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]