[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: SATA Hotplug fails



On 06/19/2009 01:54 AM, John Austin wrote:
On Thu, 2009-06-18 at 21:19 -0700, john wendel wrote:
I've got a WD external drive with an e-sata connection. Works fine if I
boot with it connected/powered.

If I hot plug it, I see the following in the messages log

Jun 18 21:09:35 godzilla2 kernel: ata1: exception Emask 0x10 SAct 0x0
SErr 0x4050000 action 0xe frozen
Jun 18 21:09:35 godzilla2 kernel: ata1: irq_stat 0x00400040, connection
status changed
Jun 18 21:09:35 godzilla2 kernel: ata1: SError: { PHYRdyChg CommWake
DevExch }
Jun 18 21:09:35 godzilla2 kernel: ata1: hard resetting link
Jun 18 21:09:41 godzilla2 kernel: ata1: link is slow to respond, please
be patient (ready=0)
Jun 18 21:09:45 godzilla2 kernel: ata1: COMRESET failed (errno=-16)
Jun 18 21:09:45 godzilla2 kernel: ata1: hard resetting link
Jun 18 21:09:46 godzilla2 kernel: ata1: SATA link up 3.0 Gbps (SStatus
123 SControl 300)
Jun 18 21:09:46 godzilla2 kernel: ata1.00: applying link speed limit
horkage to 1.5 Gbps
Jun 18 21:09:51 godzilla2 kernel: ata1: hard resetting link
Jun 18 21:09:51 godzilla2 kernel: ata1: SATA link up 1.5 Gbps (SStatus
113 SControl 310)
Jun 18 21:09:52 godzilla2 kernel: ata1.00: configured for UDMA/133
Jun 18 21:09:52 godzilla2 kernel: ata1: EH complete

I don't get a device created in /dev.

I'm running the lastest F11 32 bit

Linux godzilla2 2.6.29.4-167.fc11.i586 #1 SMP Wed May 27 17:14:37 EDT
2009 i686 i686 i386 GNU/Linux

Any words of wisdom (other than "don't do that") ?

Thanks,

John


I have two F11 machines that hotplug eSATA OK
In the back of my mind I seem to remember you have to set the BIOS to
SATA mode AHCI

I also hack PolicyKit so normal user can mount "fixed" disks

nedit /etc/PolicyKit/PolicyKit.conf so ja can mount disks OR Use
Xfce/Settings/Authorisations

<config
version="0.1">
<match
action="org.freedesktop.hal.storage.*">
     <return
result="yes"/>
</match>
</config>

I use pcmanfm as file manager when I'm playing with eSATA
as all disks (USB and eSATA) are shown and can be mounted/unmounted
Neither dolphin or thunar get it quite right yet

John



Thanks for the tip. I'll save it in case hotplug ever works.

I think my problem is a bug in the ICH7 chipset Sata controller.

Regards,

John


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]