[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F11 fix for sound on Intel HDA machines ?



On Sun, 21 Jun 2009 00:37:25 +1000
Danny Yee <danny anatomy usyd edu au> wrote:

> stan wrote:
> > This will tell you the maker and model of your HDA-Intel chip (and
> > a lot of other potentially useful information for troubleshooting).
> > You could post it here so people can see what your system
> > configuration is as well.
> > 
> > http://www.alsa-project.org/alsa-info.sh
>  
> The output from that is attached.
> 
> I had sound working briefly, then it stopped -- between tracks in
> amarok -- and now I can't get amarok or vlc to make any noise at all.
> system-config-soundcard works, however, and flash works in Firefox,
> so it's not a driver problem.
> 
> I've tried playing with alsamixer and removing and reinstalling
> pulseaudio (several times).  I've tried logging out and logging in
> again, and rebooting.
> 
> Any ideas?  I had sound working stably in Fedora 10, after many
> traumas, so I'm unhappy that it's regressed.
> 
> Danny.

There seem to be many issues with your setup.

!!ALSA Version
!!------------

Driver version:     1.0.18a
Library version:    1.0.20
Utilities version:  1.0.20

Your drivers are at 1.0.18, and as someone else said there was a lot of
work done on hda-intel from 1.0.18 to 1.0.20.  You need to update the
driver package as described earlier in the thread.

Your chip is 
!!HDA-Intel Codec information
!!---------------------------
--startcollapse--

Codec: Realtek ALC1200

This is a very new chip in the ICH10 family.

!!PCI Soundcards installed in the system
!!--------------------------------------

00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio
Controller

I could find no documentation in the alsa-driver snapshot I have
regarding this chip.  That is not a good sign.

However, the fact that it was working in F10 means that there is
probably a model that alsa is able to discover that works for this
chip, even though not designed explicitly for it.  And in fact there is
mention of the chip in the code in relation to asus-p5q.  Perhaps the
documentation just hasn't caught up to the code yet.

And alsa might have found that here as well, but this appears to be a
problem with your default device.

!!ALSA configuration files
!!------------------------

!!System wide config file (/etc/asound.conf)

#Generated by system-config-soundcard
#If you edit this file, don't run system-config-soundcard,
#all your changes here could be lost.
#HWCONF
#DEV 2
pcm.!default { type plug slave {  pcm "hw:0,2" }}
ctl.!default { type hw card 0 }

You are using hw card 0, your hda-intel for output, but you are using
device 2.  Unfortunately, this doesn't exist.

!!Aplay/Arecord output
!!------------

APLAY

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC1200 Analog [ALC1200 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC1200 Digital [ALC1200 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

If you are playing analog you need to change that hw:0,2 to hw:0,0 or if
you are playing digital you need to change that to hw:0,1

And this really should not exist in asound.conf.  Better that you copy
it to .asoundrc in your home directory and remove the /etc/asound.conf
file.  Then the system default will be the alsa default hw:0,0 and you
will use whatever you set in your .asoundrc when you log in.

Everything else looks OK as near as I can tell.  Fixing these might not
fix your problem, but if you don't fix the configuration at least there
is no chance you will get sound.

If you still have access to the F10 system, it would be good to look at
the alsa-info.sh output and see how the configuration differed from the
current system.  In particular, check if you had a .asoundrc and if
there was an /etc/modules.conf file and what was in it.

In future, before you do an upgrade, you should run the alsa-info.sh
and let it save the result online.  Then if sound doesn't work with the
new system, you have the old configuration that worked to guide you to a
solution.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]