[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

a mystery wrapped in an enigma running in a VNC session :-).



I had previously noticed that when I ran emacs in a vnc server
on my home system, the Alt key seemed to disappear.

While racking my brains to figure out what to look for,
I happened to notice that if I started emacs by hand in
a terminal, the Alt key worked fine as a prefix, so
I started binary searching through various scripts, and
finally discovered this completely inexplicable tid-bit:

I have this little script that starts emacs with a different
title if it is running as root:

#!/bin/sh
if [ `whoami` = "root" ]
then
   exec emacs --title='ROOT emacs zooty ROOT'
else
   exec emacs
fi

That script works fine in the normal X server, but when
the X server is vnc, the emacs that starts up cannot use
the Alt prefix key.

If I change /bin/sh on the first line to /bin/bash, then
the Alt key works perfectly!

Can anyone imagine any hypothesis for why execing
emacs from /bin/sh would act different than execing it
from /bin/bash, but only when in a vnc session?

This has gotta be the 2nd most mysterious thing I've
ever seen a computer do :-).


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]