[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: cups doesn't get the right ppd file



On Sun, 2009-06-21 at 09:46 -0300, Martín Marqués wrote:
> 2009/6/21 Craig White <craigwhite azapple com>
> >
> > I think you probably have to use either system-config-printer or the
> > cups web interface (http://localhost:631) and if the one you choose
> > cannot print a test page, delete the printer and set the printer up
> > again. If you want to ask the list, you probably should post the
> > contents of /etc/cups/printers.conf and maybe the output of 'tail -n
> > 12 /var/log/cups/error_log'
> 
> I am using the usual configuration programs, and I have already tried
> to delete the printer and create it again. I even removed cups and
> reinstalled it. As I tried all these things, I was looking at
> /var/log/cups/error.log (I'm not a Noob).
> 
> The thing is that each time I turn on the USB printer, the erased
> printer appears again.
----
I suppose that would be hal trying to make the printer usable...probably
not succeeding with getting the right ppd configured either.

I can tell you for sure that you should not switch back and forth
between cups web configuration and system-config-printer...choose one
and stay with it.

You may be having an SELinux issue...have you been checking the logs
(/var/log/messages and /var/log/audit/audit.log

I would probably use cups web configurator and edit whatever hal
installs because it sounds as if it gets the port correct and the PPD
wrong.

Logging is your friend, edit /etc/cups/cupsd.conf to log a lot more
details and you will know where things are breaking.

Craig



-- 
This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]