[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F11 install: cant install via NFS - ISO



On Sun, 2009-06-21 at 13:05 -0400, Andrew Parker wrote: 
> On Sun, Jun 21, 2009 at 10:33 AM, Andrea<mariofutire googlemail com> wrote:
> > Hi,
> >
> > I'm trying to install F11 via a ISO image via NFS.
> > This on a PS3.
> > I've tried the graphic installer and the text mode (passing boot option "linux text askmethod")
> > When I run in text mode the error seems to be that anaconda cannot find
> >
> > "images/install.img" at the path I have entered.
> >
> > Now, that path is *inside* the ISO and according to the installation documentation I do not need to
> > mount it.
> >
> > Reading on google I've found that F10 had some issues and one had to add the content of "images" to
> > the directory containing the image.
> 
> Its been a while since I've done an ISO over NFS, but what are you
> passing as the NFS params?  If you haven't renamed the ISO you should
> just be able to give it the directory with the ISO in it.
> 
> Alternatively, can you mount the ISO on the NFS share then install from that?
> 
Hi

You need to get at the install.img file and put it in subdirectory
images on the NFS server

In my case the iso is in /exports/global/cdrw/F11 and the final
structure looks like this 

maui.jaa.org.uk F11 1004# ls -lR /exports/global/cdrw/F11
/exports/global/cdrw/F11:
total 4172172
-rw-r--r-- 1 ja   sysadmin 4268124160 Jun  9 22:25 Fedora-11-x86_64-DVD.iso
drwxr-xr-x 2 root root           4096 Jun 10 09:45 images

/exports/global/cdrw/F11/images:
total 113780
-rw-r--r-- 1 root root 116391936 Jun 10 09:45 install.img
------------------------------------------------------
So ..
mount -o loop /exports/global/cdrw/F11/Fedora-11-x86_64-DVD.iso /mnt/zip

mkdir /exports/global/cdrw/F11/images
cp /mnt/zip/images/install.img /exports/global/cdrw/F11/images

umount /mnt/zip 
------------------------------------------------------

Then when asked at install time enter
/exports/global/cdrw/F11

John




[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]