[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Anyone got F11 NIS working?



Ralf Corsepius wrote:
Tom Horsley wrote:
I installed some fedora 11 virtual machines at work today,
and tried to configure them to use NIS logins, and the ypbind
service always times out when it tries to start.
>
All the config files I can think of to look at are identical
on my F10 vms and F11 vms, but NIS just don't work on F11
(for me :-). Anyone installed F11 and gotten NIS to work?
Sort of ...

Initially, I was facing similar issues as you.

Adding
domain <mydomain> broadcast
to /etc/yp.conf finally got NIS going again.

With FC < 11, this had not been required.

> Both selinux and firewall are disabled on these machines, so
> they shouldn't be the source of the problem.

NetworkManager? I haven't systematically tested my setup with NM, but I have been observing several NIS breaksdowns related to NM, SELinux and gdm interacting.

Ralf

Hi, I haven't followed all of this Thread but I can confirm NIS works for F11 here. My Particular config is SELinux Disabled (Note that with NIS there is a difference between disabled and permissive) and I believe I was seeing what you see when I was using NetworkManger to control networking when a system booted it couldn't bind to a ypserver until I logged in and restarted the service. I tried experimenting with when yp started and even added a line to rc.local to restart the service. This made no difference.

I then tried reverting to the network service rather than NetworkManager and things started working as I expected.

I hope this helps :)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]