[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Alpine will not show attachments



On Mon, 2 Mar 2009, Beartooth wrote:

On Mon, 02 Mar 2009 12:59:34 -0500, Tom Diehl wrote:

I am running alpine-2.00-1.fc10.x86_64 on an F10 box. If I get a message
with an html or file attachment and I try to open it, I get an error
that "Firefox can't find the file at /tmp/img--46112.htm" The correct
program opens up but I always get the can't find file errors. If the
message contains a URL then it comes up and displays properly.

Does anyone know how to troubleshoot this problem?

	First, go into M[ain Menu] > S[etup] > C[onfigure] ; type W
[hereis], then URL. Make sure the first hit says viewing is enabled. Then
W till you get to URL-viewer, and post what it's set to; you may also
want to hit the question mark and read the help -- Pine/Alpine help is
generally well written.

This looks right to me:

_TEST("test -n '${DISPLAY}'")_ /usr/bin/firefox "/usr/bin/mozilla _URL_" "/usr/bin/links _URL_"

and if I click on a link in the message firefox opens up and goes to the site
selected.


	My viewer is unset, and it uses the default; since I run Gnome,
my preferences are set in Fedora's Preferences (to Dillo -- it's fastest,
and I can always c&p the URL to something else if Dillo can't handle it).

	When viewing the message, you should see at least one line among
the headers specifying the attachment(s). Hit '>' [right angle-bracket];
that gives you just the list of what you can view. With the cursor,
highlight what you want, then hit Enter or the angle bracket again.

Well now here is the problem that I am trying to solve. when I do this
I see the following:

 1            2 lines   Text/PLAIN (charset: ISO-8859-1 "Latin 1 (Western Europe)")
   2           87 KB      Message/RFC822, "Fwd: Fw: The Plan"
   2.1.1.1    168 lines   Text/PLAIN
   2.1.1.2   ~621 lines   Text/HTML
   2.1.2       29 KB      Image/JPEG (Name: "ThePlan.jpg")

If I select the first 2 entries I get to see the attachments. If I select the
Text/HTML or Image/JPEG (Name: "ThePlan.jpg") entries I get the appropriate
viewer but a file not found error. That is the problem I am trying to describe and solve.



	When it asks, tell it Yes. If that fails, tell it Save, and
notice the name it offers (or change it, if you like). Then go into your
home directory and find it; this time you have all of Fedora to open it
with, and will usually succeed.o

Yes and that works although it is cumbersome if all I want to do is see
the html version of an email. Back in my pine days this worked. I would
like to be able to figure out what changed in Alpine. What I am not sure
about is if this feature broke when I upgraded from pine to alpine or
if there was a new version of alpine that broke it. This has been broken
for me for a long time. I just have not had the time to trouble shoot this.
Recently it is becoming a large PITA.


	Finally, if it's some cockamamie Windows app, you may have to go
looking for what in Linux handles that. For specifically html, right-
clicking on the saved file will normally let you choose any browser you
have to open it with. (I recommend Epiphany; it's the least well-
defended, and I keep it around as an expendable to try things that my
strong browsers won't handle, when I don't want to stop and figure out
which defense I have to relax for something I may only ever look at once.)

Thanks for the help,

Regards,

--
Tom Diehl		tdiehl rogueind com		Spamtrap address mtd123 rogueind com


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]