[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: required "compat" packages to run 32-bit toolchain on x86_64?



On Mon, 2 Mar 2009 14:33:47 -0500 (EST)
Robert P. J. Day wrote:

> 
>   i have an install of f10 x86_64 on which i'd like to install some
> coldfire toolchains, but these appear to be 32-bit toolchains since
> they complain about not finding the linker /lib/ld-linux.so.2.
> 
>   what is the required compatibility package(s) i need to install to
> run 32-bit packages on this system now?  thanks.
> 
>   the actual diagnostic when i try to run the cross-compiler program
> is:
> 
>   "/lib/ld-linux.so.2: bad ELF interpreter: No such file or
> directory."

It is always difficult to guess which packages have which libraries,
fortunately yum can look it up for you:

yum install /lib/ld-linux.so.2

should download whatever rpm includes that file (almost certainly
a 32 bit glibc in this particular case), then you just repeat
until you don't get any more missing lib messages and eventually
you have everything you need.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]