[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

pulseaudio deeply unreliable (Fedora 10)




OK, I've had a google, and a bit of tinkering with config. files, and I'm not really getting anywhere. PA was working OK for me in Fedora 8, but ever since I upgraded F8 to F10, it's been a right PITA.

It'll either continually stutter (e.g., when playing music often 1-2 times each track) or hiccough and crash under CPU load (firefox loading can kill it, for example).

Indeed, with my wife playing 'listen', CPU usage is PA itself is some ~20% or more. I have tried the 'tsched=0' hack, but that doesn't seem to change anything (yes, I restarted PA).


I've seen PA quit itself due to "excessive CPU usage" (I've taken to running it in an xterm to see when it's gone/what errors it's reporting). I tried the max cpu flag I found in the PA daemon conf. file, but all *that* did was just report 'Killed' when it died.

It just seems deeply unreliable. I can fairly reliably stuff it by running realplay (listening to streamed radio) under padsp, and then launching mplayer.

The only odd thing I see is some message about the ALSA and/or the kernel reporting a range of 22.0 to 22.0 db or something, "indicating a bug in the kernel driver".


So, what to try? Most googles of my symptoms lead to people who've had enough and removed it. I did even see one report trying to blame nVidia's drivers (which, regardless of veracity, is no excuse given that it was OK before).

I'd *rather* get to the bottom of the problem(s), even if it's raising bug reports and patching for now, but I'm really just fed up with the thing now. If I can't get it going within a week, next weekend it's off the machine for good.

--
[neil fnx ~]# rm -f .signature
[neil fnx ~]# ls -l .signature
ls: .signature: No such file or directory
[neil fnx ~]# exit


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]