[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Hardware upgrade -> Volume Group "VolGroup00" not found.



On Fri, Mar 6, 2009 at 10:22 AM, Richard Shaw <hobbes1069 gmail com> wrote:
> On Fri, Mar 6, 2009 at 8:37 AM, Mikkel L. Ellertson
> <mikkel infinity-ltd com> wrote:
>> Richard Shaw wrote:
>>>
>>> Hmm..... I saw some responses like that, however, my current liveusb
>>> is i386 and the install is x86_64. I tried bascially a full copy of my
>>> working system's /boot which was actually used to boot on THAT
>>> hardware until yesterday and it had the same issue.
>>>
>>> i.e. New HW -> My Desktop, My old Desktop HW -> MythBox.
>>>
>>> So the initrd I copied over to it was actually used to boot on that
>>> very same hardware.
>>>
>>> I'll have to re download F10 x86_64 as I had to delete it for space a
>>> while ago. I'll try mkinitrd but I have some doubts, unless someone
>>> can find fault with copying over a working /boot (which was used on
>>> that specific hardware previously).
>>>
>>> Thanks,
>>> Richard
>>>
>> Grub loads the kernel and initrd from /boot using the BIOS, and the
>> turns control over to the kernel. So the fact that the kernel loads
>> from /boot does not say anything about the initrd having the drivers
>> to access the hard drive.
>>
>> Mikkel
>
> Well, maybe I didn't explain what I did good enough. I copied all the
> files from My desktop computer's /boot to the /boot of the problem
> machine. Those boot files are the EXACT same boot files (including the
> initrd) used until yesterday to successfully boot the problem machine.
>
> Basically I did a roll down hardware upgrade. I got new desktop
> hardware (but kept my HD) and pushed my old desktop HW to the MythBox
> (but kept the same HD). So the hard drives have effectively stayed
> stationary while all the other hardware changed. By copying the /boot
> from my desktop HD to my Myth HD I'm effectively using the same boot
> files (kernel, initrd, etc) that were used to successfully boot the
> machine only a day ago.
>
> That being said I have the 64bit live cd downloading at home now and
> will try mkinitrd this evening.

Ok, almost there... I don't seem to be able to get mkinitrd to work. I
tried "mkinitrd -v -f initrd-2.6.27.16<etc> 2.6.27.16<etc>" and I
didn't get any output either on the screen or in a created file.

In desparation, after doing a chroot I tried yum erase/install the
kernel. It borked GRUB which I've been able to fix for the most part.
It still dumps me to the GRUB> prompt but I can root (hd0,0),
configfile /grub/grub.conf and it will try to boot.

I think doing the yum kernel install in a chroot enviornment somehow
borked plymouth too. I get all the standard kernel output but it
pauses at something like "loading keymap /some/dir/us/somefile.map"
and just sits. When I don't remove "rhgb", I get some error about not
being able to find the images or something like that which I presume
is plymouth trying to do a full graphical boot.

It looks like I've fixed it being able to find my volume group but
caused a few more problems in the process.

Any ideas?


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]