[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Rogue package



Richard England wrote:
Ashley M. Kirchner wrote:

I have an FC10 system that has kernel-2.6.27.9-159.fc10.i586 installed, yet yum nor rpm seem to think it is. It's in grub.conf, there are files in /usr/src/kernels/ pertaining to it ... but I can't remove it.

The system is running kernel-2.6.27.19-170.2.35.fc10.i686 so I don't need the other one. How do I go about instructing yum that it's installed and to remove it, if it tells me the package isn't installed?

How was the kernel installed? The rpm database probably does not know about the kernel if rpm (or yum) was not used to install it.

~~~R

If rpm was used to install, I wonder if rebuilding the rpm database might help?


rm -f /var/lib/rpm/__db*
#db_verify /var/lib/rpm/Packages
#rpm --rebuilddb

Some one else might be along with more insight....

~~R

P.S. Note that __db* has two underscores...


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]