[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: pulseaudio deeply unreliable (Fedora 10)



On Mon, Mar 9, 2009 at 1:16 PM, Tom Horsley <tom horsley att net> wrote:
> On Mon, 9 Mar 2009 12:04:46 -0500
> Richard Shaw wrote:
>
>> If you list
>> which specific applications you're having trouble with then there is
>> probably someone on the list that can help you.
>
> I don't have any trouble after removing pulseaudio
>
> Without removing pulseaudio I could never get mplayer to do the
> passthrough at all. This script plays DVDs just fine with
> audio going out to SP/DIF:
>
> amixer set IEC958 unmute
> amixer set 'IEC958 Playback AC97-SPSA' 0
> amixer set 'IEC958 Playback Source' PCM
> exec mplayer dvd://1 -alang en -ao alsa:device=hw=0.0 -ac hwdts,hwac3, -monitoraspect 16:9 -fs
>
> Then pulseaudio came along, and nothing I tried would get this
> script to work again until I tried "yum erase pulseaudio" :-).

Just tried "mplayer -ao alsa -ac hwac3, TRANSFORMERS.iso" and it
picked the right output automatically. I'm running alsa ver. 1.0.19
and pulseaudio ver. 0.9.14. Not that it matters much you can also use
the option -afm hwac3 which will try both AC3 & DTS and you don't need
the "," for fallback.

It may be an ALSA driver issue. I remember having more issues when I
was running nForce boards with AC97 audio. All my new boards are
AMD/ATI chipset with HDA audio and work quite well without much
fiddling.

Richard


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]