[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: Citrix client for F10?



fred smith wrote:
Trying to install the latest Citrix client (downloaded from Citrix) and it
insists on libXm.so.4. I have only libxm.so.2.

The citrix web page says it requires OpenMOTIF 2.3.1 or later. I see Fedora isn't distributinig OpenMOTIF, but instead lesstif, which seems to
have only libXm.so.2.0.1.

I've tried: ln -s /usr/lib/libXm.so.2.0.1 /usr/lib/libXm.so.4
but that doesn't help, RPM still complains it needs libXm.so.4.

Downloading OpenMOTIF requires registration, which I'm not especially
interested in doing.

Anybody know how to get this working on F10?

It can be done, I do it. You need a copy of openmotif-2.2.3-10.FC4.2.i386.rpm. From my notes:

1) yum install libXp.i386

2) open openmotif-2.2.3-10.FC4.2.i386.rpm using file-roller, and extract the libXm.so.3.0.2 to /usr/lib

3) ln -s /usr/lib/libXm.so.3.0.2 /usr/lib/libXm.so.3

4) rpm -ivh ICAClient*

5) ln -s /usr/lib/ICAClient/npica.so /usr/lib/mozilla/plugins/

6) chcon -t textrel_shlib_t /usr/lib/ICAClient/npica.so


Hope this helps.

- Mike


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]