[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: NM fails to connect when booting ?? -[SOLVED]



On Wed, 2009-03-18 at 17:35 +0000, Matthew Saltzman wrote:
> On Wed, 2009-03-18 at 11:46 -0400, William Case wrote:
> > Hi;
> > 
> > On Wed, 2009-03-18 at 14:26 +0200, Antti J. Huhtala wrote:
> > > ke, 2009-03-18 kello 08:22 +0100, Kevin Kofler kirjoitti:
> > > > William Case wrote:

> > 
> 
> The lack of documentation is regrettable, but I haven't had much trouble
> lately making it do anything I've tried.  (Admittedly, I haven't tried
> everything possible.  In particular, I haven't tried to start a wireless
> connection at boot, which seems to be the most common problem scenario.)
> 
> > I actually think that NM is a great improvement over
> > system-config-network.  That is one of the reasons why I have brought
> > any problems I am having with NM to this mailing list.  I would rather
> > get NM working for me than return to system-config-network.  
> > 
> > For ordinary users or users who would rather spend their time on things
> > other than tweaking their wireless or wired network -- keep it
> > simple,stupid (KISS).  The problem is, if you want to make some minor
> > changes or alterations you have to dive into the arcane nether world of
> > networking.
> > 
> > I would suggest:
> >      1. A button that allows you to disconnect (turn it off) temporarily
> >         -- say to the next boot.
> 
> Right-click the applet and uncheck Enable Networking or Enable Wireless,
> as appropriate.

Sorry to everyone.  Was trying to disconnect by left-click then clicking
on "System eth0."

> 
> >      2. An "Edit Connections" that actually allows you to edit
> >         connections. 
> 
> All my wireless connections are editable from the applet.  The wired
> connections are editable from s-c-network, as mentioned above.
> Apparently Fedora devs think that that's the way to go.
> 
> >      3. Tie editing to root, if necessary, with the usual sudo or su -
> >         popup.
> 
> See s-c-network.  It might be nice if nm-applet started s-c-network when
> you tried to edit a "non-editable" connection, but if this is where an
> "ordinary user" would think to
> edit /etc/sysconfig/network-scripts/ifcfg-eth0, then s-c-network the way
> to do it.
> 
> >      4. Clearly show in the gui how to turn ONBOOT to yes or no.
> 
> See s-c-network.
> 
> BTW, I have a desktop with a recent F10 install, fully up to date.  It
> has only a wired interface.  That interface comes up at boot (before
> login) with no problem using NM, not using the network service.  I have
> not made any changes to its /etc/sysconfig/network-scripts/ifcfg-eth0.
> s-c-network shows that it is on at startup and controlled by NM.
> 

Trouble in paradise then.  I have two recent F10 installs, fully up to
date.  Neither had ifcfg-eth0 BOOTUP=yes.

> >      5. A Default button that returns any adjustments to the default
> >         settings.
> >      6. A manual that is useful.
> > 
> > And, by the way, what does the "never" that is placed at the end "System
> > eth0" line mean?
> 
> Means "Never connected to that interface."  Apparently incorrect or
> meaningless for System eth0, but seems to work for wireless.
> 
I suppose I am being a bit tentative because I got into a major mixup in
F9 between NM and system-config-network.  I just wish Fedora would make
the network connecting completely one or the other. 
-- 
Regards Bill
Fedora 10, Gnome 2.24.3
Evo.2.24.5, Emacs 22.3.1


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]