[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F10 Things Breaking



On Saturday 21 March 2009 23:05, Conor Mac Aoidh wrote:
> I have been having problems with my Fedora 10 installation recently. I
> don't know what it is but a hell of a lot of things are breaking. First I
> installed an upgrade that broke Yum, which I have fixed. Then I installed
> another update that seems to have broken a number of things....

What exactly did you do? If you use yum to install stuff, it should not break. 
If you manually installed something (why?), that is probably the reason that 
things got broken.

> Also I recently installed the kooldock which operates similar to a Mac OSX
> dock. It was working but now when I click on one of the doc items I get the
> following error:

Kooldock is a very lame substitute for the real "Mac OSX dock" (tried both 
myself). Incidentally, that real "Mac OSX dock" is called cairo-dock, and is 
available for Fedora:

yum install cairo-dock

Maybe you need to have rpmfusion repo enabled, I am not sure... :-)

> I would appreciate if anyone could figure out what the hell is going on
> because it's really starting to annoy me! I have tried forums but no one
> seems to know the answer!

You have probably broken your own system yourself. Basic rules: never install 
a rpm binary by hand unless you are sure it is packaged for F10 and you are 
sure you know exactly what you are doing. And if it is packaged for F10, use 
yum instead of manually installing. If you compiled something from source, be 
sure to install it in /usr/local so that it doesn't conflict with existing 
packages (of course, you can't be 100% sure even then).

If you tell us how did you manage to "install an upgrade that broke Yum", 
maybe someone can help to clean things up. Otherwise, you get to keep the 
pieces...

HTH :-)
Marko



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]