[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: F10 Things Breaking

On Sun, Mar 22, 2009 at 12:14 AM, Marko Vojinovic <vvmarko panet co yu> wrote:
On Saturday 21 March 2009 23:05, Conor Mac Aoidh wrote:
> I have been having problems with my Fedora 10 installation recently. I
> don't know what it is but a hell of a lot of things are breaking. First I
> installed an upgrade that broke Yum, which I have fixed. Then I installed
> another update that seems to have broken a number of things....

What exactly did you do? If you use yum to install stuff, it should not break.
If you manually installed something (why?), that is probably the reason that
things got broken.

I try my best to only install stuff with yum. It's not possible all of the time though... What is the point of having a package manager if it does not manage your packages!?

> Also I recently installed the kooldock which operates similar to a Mac OSX
> dock. It was working but now when I click on one of the doc items I get the
> following error:

Kooldock is a very lame substitute for the real "Mac OSX dock" (tried both
myself). Incidentally, that real "Mac OSX dock" is called cairo-dock, and is
available for Fedora:

yum install cairo-dock

I actually used cairo-dock before and got rid of it. I think that kooldock is much better. I couldn't get cairo to do transparent backgrounds and kooldock is much more customisable.

Maybe you need to have rpmfusion repo enabled, I am not sure... :-)

How do I check? Is that a dis-advantage?

> I would appreciate if anyone could figure out what the hell is going on
> because it's really starting to annoy me! I have tried forums but no one
> seems to know the answer!

You have probably broken your own system yourself. Basic rules: never install
a rpm binary by hand unless you are sure it is packaged for F10 and you are
sure you know exactly what you are doing. And if it is packaged for F10, use
yum instead of manually installing. If you compiled something from source, be
sure to install it in /usr/local so that it doesn't conflict with existing
packages (of course, you can't be 100% sure even then).

I don't do that anyway...

If you tell us how did you manage to "install an upgrade that broke Yum",
maybe someone can help to clean things up. Otherwise, you get to keep the

I really don't think that I have done anything to cause these things breaking... But then again I'm no Linux genius! For example I discovered that the sound problem that I have been having recently was caused by a kernal update. There's more info on that here: http://linux.derkeiler.com/Mailing-Lists/Fedora/2009-01/msg01187.html

As for the Yum problem, I don't know exactly what happened. Yum was working fine then I installed an update and from then on I could not use Yum, not even to install updates. I fixed it by running this:

rm -f /var/lib/rpm/__db*
rpm --rebuilddb



"If you make a general statement, a programmer says, 'Yes, but...'
while a designer says, 'Yes, and...'"


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]