[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]

Re: konsole trouble



On Tue, 2009-03-24 at 22:49 -0400, Tom Diehl wrote: 
> On Tue, 24 Mar 2009, Gerhard Magnus wrote:
> 
> > On Tue, 2009-03-24 at 11:09 -0600, Robert Singleton wrote:
> >> I'm running Fedora 10 under the Gnome desktop on a Toshiba laptop. Last
> >> night I seem to have messed up the konsole application (not sure how,
> >> but I think it turned dark, wouldn't respond, so I killed the app), and
> >> now it will not launch (although Terminal will launch, but I don't
> >> really like Terminal). The problem is also present with other user
> >> accounts, so it doesn't seem like it's a local profile setting. The
> >> Microsoft fix of rebooting does not solve the problem either. Any
> >> suggestions? Thanks very much in advance if you can help me.
> >>
> >> Robert Singleton
> >
> > This also happened to me this morning -- konsole just won't launch for
> > no apparent reason. I've switched to Terminal for the time being....
> 
> For me it crashes. I have tracked it down to a problem with the configuration
> settings that I have used for the last 10+ years. It seems that they decided
> to remove the vt420pc terminal type from the list of valid choices. So far I
> cannot find any documentation that explains this change. I have found that
> there is a file  /home/tdiehl/.kde/share/apps/konsole/Shell.profile that
> contains a line KeyBindings=vt420pc. If I rm that line konsole will start.
> If that line is there then konsole crashes.
> 
> So, does anyone know where I can find the documentation that explains this
> change and how to get my keybindings to work properly again?
> 
> Oh by the way this is not only screwed up on my F10 system I have the same
> problem on F9.
> 
> FWIW:
> 
> (tigger pts8) # rpm -q kdebase
> kdebase-4.2.1-2.fc10.x86_64
> (tigger pts8) #
> 
> Regards,
> 
> -- 
> Tom Diehl		tdiehl rogueind com		Spamtrap address mtd123 rogueind com
> 

Hi

Same/similar problem with konsole

kdebase-4.2.1-2.fc10.x86_64

Error message when run from a terminal

[fred meon konsole]$ konsole
konsole(3835): Attempt to use QAction "change-profile" with KXMLGUIFactory!
[fred meon konsole]$ Undecodable sequence: \001b(hex)[?1034h

The konsole terminal opens OK in this mode

To get konsole to launch OK from xfce panel by setting it to run in "terminal" mode
with konsole --nofork shows the same error

konsole(3978): Attempt to use QAction "change-profile" with KXMLGUIFactory! 
Undecodable sequence: \001b(hex)[?1034h

Edited/removed ~/.kde/share/apps/konsole/Shell.profile
or the whole of ~/.kde/share/apps/konsole
makes no difference - so suggest that its not the contents of ~/.kde/share/apps/konsole
causing the problem

John







[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]